summaryrefslogtreecommitdiff
path: root/x11-libs/fltk/fltk-1.3.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/fltk/fltk-1.3.9999.ebuild')
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild42
1 files changed, 22 insertions, 20 deletions
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index 3c620a6587b..3f16affaed5 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-
inherit autotools eutils fdo-mime flag-o-matic subversion
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -26,16 +25,16 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
cairo? ( x11-libs/cairo )
- opengl? ( virtual/opengl )
+ opengl? ( virtual/glu virtual/opengl )
xinerama? ( x11-libs/libXinerama )
- xft? ( x11-libs/libXft )"
-DEPEND="${RDEPEND}
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
x11-proto/xextproto
doc? ( app-doc/doxygen )
- xinerama? ( x11-proto/xineramaproto )"
-
-FLTK_INCDIR=${EPREFIX}/usr/include/fltk
-FLTK_LIBDIR=${EPREFIX}/usr/$(get_libdir)/fltk
+ xinerama? ( x11-proto/xineramaproto )
+"
src_prepare() {
rm -rf zlib jpeg png || die
@@ -75,22 +74,25 @@ src_prepare() {
}
src_configure() {
+ FLTK_INCDIR=${EPREFIX}/usr/include/fltk
+ FLTK_LIBDIR=${EPREFIX}/usr/$(get_libdir)/fltk
+
econf \
- --includedir=${FLTK_INCDIR}\
- --libdir=${FLTK_LIBDIR} \
- --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --enable-largefile \
- --enable-shared \
- --enable-xdbe \
- --disable-localjpeg \
- --disable-localpng \
- --disable-localzlib \
- $(use_enable debug) \
$(use_enable cairo) \
+ $(use_enable debug) \
$(use_enable opengl gl) \
$(use_enable threads) \
$(use_enable xft) \
- $(use_enable xinerama)
+ $(use_enable xinerama) \
+ --disable-localjpeg \
+ --disable-localpng \
+ --disable-localzlib \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --enable-largefile \
+ --enable-shared \
+ --enable-xdbe \
+ --includedir=${FLTK_INCDIR} \
+ --libdir=${FLTK_LIBDIR}
}
src_compile() {