summaryrefslogtreecommitdiff
path: root/x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild')
-rw-r--r--x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild b/x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild
new file mode 100644
index 00000000000..3957e2ade33
--- /dev/null
+++ b/x11-libs/gtk+extra/gtk+extra-3.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Useful Additional GTK+ widgets"
+HOMEPAGE="http://gtkextra.sourceforge.net"
+SRC_URI="mirror://sourceforge/gtkextra/gtkextra-${PV}.tar.gz"
+
+LICENSE="FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection static-libs test"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.12.0:2
+ dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# dev-libs/gobject-introspection-common needed for eautoreconf
+
+S="${WORKDIR}/gtkextra-${PV}"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-glade=no \
+ --disable-man \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}