summaryrefslogtreecommitdiff
path: root/x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild')
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild
new file mode 100644
index 00000000000..a9187de1a09
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/${PN}"
+SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libinput-1.8.0
+ x11-misc/xdotool
+ x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+ dev-util/desktop-file-utils
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+
+pkg_postinst() {
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}