summaryrefslogtreecommitdiff
path: root/x11-misc/sw-notify-send
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sw-notify-send')
-rw-r--r--x11-misc/sw-notify-send/Manifest2
-rw-r--r--x11-misc/sw-notify-send/metadata.xml16
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-0.1.1.ebuild27
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild38
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-9999.ebuild52
5 files changed, 135 insertions, 0 deletions
diff --git a/x11-misc/sw-notify-send/Manifest b/x11-misc/sw-notify-send/Manifest
new file mode 100644
index 00000000000..faba77b3c92
--- /dev/null
+++ b/x11-misc/sw-notify-send/Manifest
@@ -0,0 +1,2 @@
+DIST sw-notify-send-0.1.1.tar.bz2 54661 SHA256 b178554b2359ccad72aefff3c986356b96a541602d08b819565dd8d91ca3e4d4
+DIST tinynotify-send-1.2.1.tar.bz2 266078 SHA256 72c5f4451348b0a06dd57efb5de75273e47f7e35ae04df9a3dd1c64be1e71e65 SHA512 f416db09fa95f04d771610af7ae8953192027b8606c53f54efe514c4d33b59e8dc362676004a036c2dd7e7c7cf03b077ee9b753839efbcb181c5724f43efa58d WHIRLPOOL 2e82b67111db19aa52e293feea167e53ef73bf04a043049543082cf9eea64f75bbfe9788e323dd19d081b5cab43ff469e370810fd6bbc70707329cacfb560411
diff --git a/x11-misc/sw-notify-send/metadata.xml b/x11-misc/sw-notify-send/metadata.xml
new file mode 100644
index 00000000000..feaa57e4dc7
--- /dev/null
+++ b/x11-misc/sw-notify-send/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/tinynotify-send/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/tinynotify-send</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/sw-notify-send/sw-notify-send-0.1.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-0.1.1.ebuild
new file mode 100644
index 00000000000..f1a686cf783
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit autotools-utils
+
+DESCRIPTION="A system-wide notification wrapper for notify-send"
+HOMEPAGE="https://github.com/mgorny/sw-notify-send/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-process/procps"
+DEPEND="${RDEPEND}"
+
+# The lack of x11-libs/libnotify RDEPEND is intentional as:
+# 1) The notification daemon may be running in a libnotify-enabled
+# chroot system, while keeping the host system libnotify-free (in this
+# case sw-notify-send enters the chroot first);
+# 2) Having any kind of a notification daemon implies having libnotify
+# installed. And if none is running, notify-send is not called anyway.
+
+DOCS=( README )
diff --git a/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
new file mode 100644
index 00000000000..7180d8b6de4
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="mirror://github/mgorny/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ myeconfargs=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
new file mode 100644
index 00000000000..6cf23d120d5
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/tinynotify-send.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://bitbucket.org/mgorny/tinynotify-send/"
+SRC_URI="https://www.bitbucket.org/mgorny/${MY_PN}/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify:0=
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+#if LIVE
+EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ dev-util/gtk-doc"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ autotools-utils_src_configure
+}