summaryrefslogtreecommitdiff
path: root/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild')
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild
new file mode 100644
index 00000000000..820245ebabc
--- /dev/null
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to switch and preview GTK+ theme"
+HOMEPAGE="http://packages.qa.debian.org/g/gtk-theme-switch.html"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:${GCC}:$(CC) $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} -Wall" || die
+}
+
+src_install() {
+ newbin ${PN}2 ${PN} || die
+ newman ${PN}2.1 ${PN}.1 || die
+ dodoc ChangeLog readme todo
+}