summaryrefslogtreecommitdiff
path: root/x11-wm/ctwm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ctwm')
-rw-r--r--x11-wm/ctwm/Manifest3
-rw-r--r--x11-wm/ctwm/ctwm-3.7.ebuild56
-rw-r--r--x11-wm/ctwm/ctwm-3.8.2.ebuild82
-rw-r--r--x11-wm/ctwm/ctwm-3.8a-r1.ebuild73
-rw-r--r--x11-wm/ctwm/files/ctwm-3.6-r1-gentoo.diff55
-rw-r--r--x11-wm/ctwm/metadata.xml5
6 files changed, 274 insertions, 0 deletions
diff --git a/x11-wm/ctwm/Manifest b/x11-wm/ctwm/Manifest
new file mode 100644
index 00000000000..e8d23b03106
--- /dev/null
+++ b/x11-wm/ctwm/Manifest
@@ -0,0 +1,3 @@
+DIST ctwm-3.7.tar.gz 1139461 SHA256 fa16dbaef6992cdbcdbe05a9dc12c2c16910f5e51a2df54607aeb74f9b4a5171
+DIST ctwm-3.8.2.tar.xz 549984 SHA256 574d67a8a69f2f1ebaa71aa40cc50667e814f74b51f5db8886e2def6a3e0900f SHA512 4633b7bf7b8528ecfd2a753f443fd5286fd394df37ebe885138d30a498f0d721076835d135974a2bd11ca9c32ffd288f84788cb0407ae346a29c5f6371dca497 WHIRLPOOL 6416ecff3230e823bf52219ae8538862a6ed8e66506a16111b715431e3dd007e81d4b1ac6b83321ec12ca95926fb7747b1927626458fa51fb3205589c3f07eda
+DIST ctwm-3.8a.tar.gz 738226 SHA256 39322cc6b0d12dc286af0944f9a10d3a099a5f04c5d9c47b75742cdf65dbd4a4
diff --git a/x11-wm/ctwm/ctwm-3.7.ebuild b/x11-wm/ctwm/ctwm-3.7.ebuild
new file mode 100644
index 00000000000..d73737cbbb0
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-3.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="http://ctwm.free.lp.se/"
+SRC_URI="http://ctwm.free.lp.se/dist/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ app-text/rman
+ virtual/jpeg
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_compile() {
+ sed -i -e "s@\(CONFDIR =\).*@\1 /etc/X11/twm@g" Imakefile \
+ || die "sed failed"
+
+ cp Imakefile.local-template Imakefile.local
+
+ xmkmf || die "xmkmf failed"
+ make TWMDIR=/usr/share/${PN} || die "make failed"
+}
+
+src_install() {
+ make BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ TWMDIR=/usr/share/${PN} \
+ DESTDIR="${D}" install || die "make install failed"
+
+ make MANPATH=/usr/share/man \
+ DOCHTMLDIR=/usr/share/doc/${PF}/html \
+ DESTDIR="${D}" install.man || die "make install.man failed"
+
+ echo "#!/bin/sh" > ${T}/ctwm
+ echo "/usr/bin/ctwm" >> ${T}/ctwm
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/ctwm
+
+ dodoc CHANGES README* TODO* PROBLEMS
+ dodoc *.ctwmrc*
+}
diff --git a/x11-wm/ctwm/ctwm-3.8.2.ebuild b/x11-wm/ctwm/ctwm-3.8.2.ebuild
new file mode 100644
index 00000000000..88a435c6b71
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-3.8.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="http://ctwm.org/"
+SRC_URI="${HOMEPAGE}dist/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ app-text/rman
+ virtual/jpeg
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ # overflow bug 338180
+ sed -i menus.c -e "/char modStr/ s/5/6/" || die
+
+ # implicit 'isspace'
+ sed -i parse.c -e "/<stdio.h>/ a#include <ctype.h>" || die
+
+ sed -i Imakefile -e "/^CONFDIR/s@=.*@= /etc/X11/twm@g" || die
+
+ cp Imakefile.local-template Imakefile.local
+
+ # TODO: Add GNOME support
+ sed -i Imakefile.local -e '/^#define GNOME/d' || die
+}
+
+src_configure() {
+ append-cppflags -DXPM -DJPEG
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ TWMDIR=/usr/share/${PN}
+}
+
+src_install() {
+ emake BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ TWMDIR=/usr/share/${PN} \
+ DESTDIR="${D}" install
+
+ emake MANPATH=/usr/share/man \
+ DOCHTMLDIR=/usr/share/doc/${PF}/html \
+ DESTDIR="${D}" install.man
+
+ echo "#!/bin/sh" > ${T}/ctwm
+ echo "/usr/bin/ctwm" >> ${T}/ctwm
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/ctwm
+
+ dodoc CHANGES README* TODO* PROBLEMS
+ dodoc *.ctwmrc*
+}
diff --git a/x11-wm/ctwm/ctwm-3.8a-r1.ebuild b/x11-wm/ctwm/ctwm-3.8a-r1.ebuild
new file mode 100644
index 00000000000..665e0e60aa8
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-3.8a-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="http://ctwm.free.lp.se/"
+SRC_URI="http://ctwm.free.lp.se/dist/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ app-text/rman
+ virtual/jpeg
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -e "/char modStr/ s/5/6/" -i menus.c || die #overflow bug 338180
+ sed -e "/<stdio.h>/ a#include <ctype.h>" -i parse.c || die #implicit 'isspace'
+ sed -i Imakefile \
+ -e "s@\(CONFDIR =\).*@\1 /etc/X11/twm@g" \
+ || die
+
+ cp Imakefile.local-template Imakefile.local
+
+ # TODO: Add GNOME support
+ sed -i Imakefile.local \
+ -e '/^#define GNOME/d' \
+ || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ TWMDIR=/usr/share/${PN} \
+ || die
+}
+
+src_install() {
+ make BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ TWMDIR=/usr/share/${PN} \
+ DESTDIR="${D}" install || die
+
+ make MANPATH=/usr/share/man \
+ DOCHTMLDIR=/usr/share/doc/${PF}/html \
+ DESTDIR="${D}" install.man || die
+
+ echo "#!/bin/sh" > ${T}/ctwm
+ echo "/usr/bin/ctwm" >> ${T}/ctwm
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/ctwm || die
+
+ dodoc CHANGES README* TODO* PROBLEMS || die
+ dodoc *.ctwmrc* || die
+}
diff --git a/x11-wm/ctwm/files/ctwm-3.6-r1-gentoo.diff b/x11-wm/ctwm/files/ctwm-3.6-r1-gentoo.diff
new file mode 100644
index 00000000000..d6f9e5cee3d
--- /dev/null
+++ b/x11-wm/ctwm/files/ctwm-3.6-r1-gentoo.diff
@@ -0,0 +1,55 @@
+diff -urN ctwm-3.6.ORIG/gram.y ctwm-3.6/gram.y
+--- ctwm-3.6.ORIG/gram.y 2001-12-12 00:38:52.000000000 +0900
++++ ctwm-3.6/gram.y 2004-02-07 06:43:37.067787401 +0900
+@@ -419,14 +419,13 @@
+ | WINDOW_RING { list = &Scr->WindowRingL; }
+ win_list
+ | WINDOW_RING { Scr->WindowRingAll = TRUE; }
+- ;
+ | WINDOW_RING_EXCLUDE { if (!Scr->WindowRingL)
+ Scr->WindowRingAll = TRUE;
+ list = &Scr->WindowRingExcludeL; }
+ win_list
+-
+ | WINDOW_GEOMETRIES { }
+ wingeom_list
++ ;
+
+ noarg : KEYWORD { if (!do_single_keyword ($1)) {
+ twmrc_error_prefix();
+@@ -683,8 +682,8 @@
+ | wingeom_entries wingeom_entry
+ ;
+
+-wingeom_entry : string string { AddToList (&Scr->WindowGeometries, $1, $2) }
+-
++wingeom_entry : string string { AddToList (&Scr->WindowGeometries, $1, $2); }
++ ;
+
+
+ squeeze : SQUEEZE_TITLE {
+@@ -835,6 +834,7 @@
+ AddToClientsList ($1, client);
+ }
+
++ ;
+ occupy_window_list : LB occupy_window_entries RB {}
+ ;
+
+@@ -845,7 +845,7 @@
+ occupy_window_entry : string {
+ AddToClientsList (workspace, $1);
+ }
+-
++ ;
+ icon_list : LB icon_entries RB {}
+ ;
+
+@@ -962,6 +962,7 @@
+ RemoveDQuote(ptr);
+ $$ = (unsigned char*)ptr;
+ }
++ ;
+ number : NUMBER { $$ = $1; }
+ ;
+
diff --git a/x11-wm/ctwm/metadata.xml b/x11-wm/ctwm/metadata.xml
new file mode 100644
index 00000000000..4538a68724a
--- /dev/null
+++ b/x11-wm/ctwm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>