summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild
new file mode 100644
index 00000000000..3ff4f023e5e
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND=">=gnome-base/librsvg-2.36.2
+ x11-libs/gtk+:2
+ >=x11-libs/libwnck-2.12:1
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5
+ >=xfce-base/garcon-0.1.5
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfce4-panel-4.11"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/xfce4-settings-4.11"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README )
+}