summaryrefslogtreecommitdiff
path: root/packages/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/base.nix')
-rw-r--r--packages/base.nix92
1 files changed, 92 insertions, 0 deletions
diff --git a/packages/base.nix b/packages/base.nix
new file mode 100644
index 0000000..c06b939
--- /dev/null
+++ b/packages/base.nix
@@ -0,0 +1,92 @@
+{ config, pkgs, ... }:
+{
+ environment.systemPackages = with pkgs; [
+ ag
+ apg
+ aria2
+ aspell
+ bash-completion
+ bashInteractive
+ cacert
+ clamav
+ cryptsetup
+ diffstat
+ diffutils
+ dnsutils
+ dos2unix
+ dot2tex
+ duplicity
+ entr
+ exiv2
+ fd
+ ffmpeg
+ file
+ findutils
+ fontconfig
+ fzf
+ gawk
+ git
+ gnugrep
+ gnupg
+ gnused
+ gnutar
+ gnutls
+ gptfdisk
+ groff
+ htop
+ httperf
+ iotop
+ iperf
+ jq
+ less
+ linux-overlay
+ lsof
+ ltrace
+ #mitmproxy
+ mkpasswd
+ mtr
+ ncdu
+ nfs-utils
+ nixOverlay
+ nmap
+ openssh
+ openssl
+ openvpn
+ parallel
+ patch
+ patchutils
+ pciutils
+ pstree
+ pv
+ pwgen
+ rclone
+ renameutils
+ ripgrep
+ rsync
+ screen
+ silver-searcher
+ smartmontools
+ socat
+ stow
+ strace
+ tcpdump
+ time
+ tmux
+ tree
+ unzip
+ vim
+ w3m
+ watch
+ watchman
+ wavemon
+ wget
+ whois
+ wordnet
+ xsv
+ xz
+ yubikey-personalization
+ zip
+ zsh
+ zsh-syntax-highlighting
+ ];
+}