summaryrefslogtreecommitdiff
path: root/phenex/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'phenex/configuration.nix')
-rw-r--r--phenex/configuration.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/phenex/configuration.nix b/phenex/configuration.nix
new file mode 100644
index 0000000..4dcf769
--- /dev/null
+++ b/phenex/configuration.nix
@@ -0,0 +1,41 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ ./hardware-configuration.nix
+ ./secrets.nix
+ ./services/clamav.nix
+ ./services/firewall.nix
+ ./services/dnsmasq.nix
+ ./services/sound.nix
+ ./services/x11.nix
+ ./services/x11-laptop.nix
+ ./services/kde.nix
+ ./services/compton.nix
+ ./services/haveged.nix
+ ./system/i18n.nix
+ ./system/networking.nix
+ ./system/packages.nix
+ ./system/timezone.nix
+ ./system/users.nix
+ ./system/yubikey-gpg.nix
+ ];
+
+ networking.hostName = "phenex";
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ programs.mtr.enable = true;
+ programs.gnupg.agent = { enable = true; enableSSHSupport = true; };
+
+ # This value determines the NixOS release with which your system is to be
+ # compatible, in order to avoid breaking some software such as database
+ # servers. You should change this only after NixOS release notes say you
+ # should.
+ system.stateVersion = "19.03"; # Did you read the comment?
+
+}