summaryrefslogtreecommitdiff
path: root/services/podman.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/podman.nix')
-rw-r--r--services/podman.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/services/podman.nix b/services/podman.nix
index f6a8c49..f3b5f51 100644
--- a/services/podman.nix
+++ b/services/podman.nix
@@ -5,15 +5,16 @@
enable = true;
dockerCompat = true;
};
- containers.containersConf.extraConfig = ''
- [engine.runtimes]
- runc = [
- "${pkgs.runc}"
- ]
- crun = [
- "${pkgs.crun}"
- ]
- '';
+ containers.containersConf.settings = {
+ engine.runtimes = {
+ runc = [
+ "${pkgs.runc}"
+ ];
+ crun = [
+ "${pkgs.crun}"
+ ];
+ };
+ };
oci-containers.backend = "podman";
};
}