summaryrefslogtreecommitdiff
path: root/system/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/nix.nix')
-rw-r--r--system/nix.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/system/nix.nix b/system/nix.nix
new file mode 100644
index 0000000..7d8971d
--- /dev/null
+++ b/system/nix.nix
@@ -0,0 +1,16 @@
+{ config, pkgs, ... }:
+{
+ nix = {
+ trustedUsers = [ "@wheel" ];
+ daemonIONiceLevel = 3;
+ daemonNiceLevel = 17;
+ gc = {
+ automatic = true;
+ options = "--delete-older-than 14d";
+ };
+ optimise = {
+ automatic = true;
+ dates = [ "Sun 03:45" ];
+ };
+ };
+}