aboutsummaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2020-10-14 10:05:44 -0600
committerKenny Ballou <kballou@devnulllabs.io>2020-12-15 14:04:46 -0700
commit418ec7b94aa8202e5f5f0a59f2bb97a7c0510068 (patch)
tree0a08e1653ba5d8efc527bbaf4e5914ffb9c8b6b9 /home.nix
parent164cd37871e6235584ce23f3a0bf516a51b31489 (diff)
downloaddotfiles-418ec7b94aa8202e5f5f0a59f2bb97a7c0510068.tar.gz
dotfiles-418ec7b94aa8202e5f5f0a59f2bb97a7c0510068.tar.xz
dots: now for something completely different
Use home-manager to configure user packages, dotfiles, and various other configurations. Add home-manager configuration for installing and managing user packages and profiles. Convert nearly all configuration to use home-manager to install and link configuration files. In no particular order of reference, I've used and/or referenced the following configurations and posts for this homeification: [[0], [1], [2], [3], [4], [5], [6], [7], [8], [9], [10]]. [0]: https://gitlab.com/NobbZ/nix-home-manager-dotfiles [1]: https://www.malloc47.com/migrating-to-nixos/ [2]: https://lucperkins.dev/blog/home-manager/ [3]: https://github.com/jwiegley/nix-config [4]: https://www.thedroneely.com/posts/declarative-user-package-management-in-nixos/ [5]: https://hugoreeves.com/posts/2019/nix-home/ [6]: https://rycee.gitlab.io/home-manager/ [7]: https://rycee.net/posts/2017-07-02-manage-your-home-with-nix.html [8]: https://github.com/abcdw/rde [9]: https://github.com/ryantm/dotfiles [10]: https://git.sr.ht/~vdemeester/home Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/home.nix b/home.nix
new file mode 100644
index 00000000..3105e15b
--- /dev/null
+++ b/home.nix
@@ -0,0 +1,33 @@
+{ pkgs, config, ... }:
+let
+ lib = pkgs.stdenv.lib;
+
+ utils = import ./nix/utils.nix { pkgs = pkgs; };
+ home-dir = builtins.getEnv "HOME";
+ xdg = config.xdg;
+ nixpath = "${home-dir}/.nix-profile";
+in
+{
+ nixpkgs = {
+ config = import ./config/nixpkgs/config.nix;
+ overlays = [
+ (import (builtins.fetchTarball {
+ url = https://github.com/nix-community/emacs-overlay/archive/32486e6e9e4300721b0c071fda5465cec2086eea.tar.gz;
+ }))
+ ] ++ utils.importDirs ./overlays;
+ };
+ imports = (utils.importDirs ./config) ++ [
+ ./config/xresources/dpi-96.nix
+ ./config/email/devnulllabs.nix
+ ./config/email/boisestate.nix
+ ];
+ programs.home-manager.enable = true;
+ home = {
+ extraOutputsToInstall = [ "doc" "info" "devdoc" "man"];
+ packages = (import ./packages.nix pkgs);
+ sessionPath = [
+ "${home-dir}/.local/bin"
+ ];
+ };
+ systemd.user.sessionVariables = config.home.sessionVariables;
+}