aboutsummaryrefslogtreecommitdiff
path: root/packages.nix
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2020-10-14 10:05:44 -0600
committerKenny Ballou <kballou@devnulllabs.io>2020-12-15 14:04:46 -0700
commit418ec7b94aa8202e5f5f0a59f2bb97a7c0510068 (patch)
tree0a08e1653ba5d8efc527bbaf4e5914ffb9c8b6b9 /packages.nix
parent164cd37871e6235584ce23f3a0bf516a51b31489 (diff)
downloaddotfiles-418ec7b94aa8202e5f5f0a59f2bb97a7c0510068.tar.gz
dotfiles-418ec7b94aa8202e5f5f0a59f2bb97a7c0510068.tar.xz
dots: now for something completely different
Use home-manager to configure user packages, dotfiles, and various other configurations. Add home-manager configuration for installing and managing user packages and profiles. Convert nearly all configuration to use home-manager to install and link configuration files. In no particular order of reference, I've used and/or referenced the following configurations and posts for this homeification: [[0], [1], [2], [3], [4], [5], [6], [7], [8], [9], [10]]. [0]: https://gitlab.com/NobbZ/nix-home-manager-dotfiles [1]: https://www.malloc47.com/migrating-to-nixos/ [2]: https://lucperkins.dev/blog/home-manager/ [3]: https://github.com/jwiegley/nix-config [4]: https://www.thedroneely.com/posts/declarative-user-package-management-in-nixos/ [5]: https://hugoreeves.com/posts/2019/nix-home/ [6]: https://rycee.gitlab.io/home-manager/ [7]: https://rycee.net/posts/2017-07-02-manage-your-home-with-nix.html [8]: https://github.com/abcdw/rde [9]: https://github.com/ryantm/dotfiles [10]: https://git.sr.ht/~vdemeester/home Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix151
1 files changed, 151 insertions, 0 deletions
diff --git a/packages.nix b/packages.nix
new file mode 100644
index 00000000..49f1bfd9
--- /dev/null
+++ b/packages.nix
@@ -0,0 +1,151 @@
+{ pkgs, ... }:
+with pkgs; [
+ (pass.withExtensions (ext: with ext; [ pass-otp pass-genphrase ]))
+ ag
+ alacritty
+ apg
+ aria2
+ aspell
+ aspellDicts.en
+ aspellDicts.en-computers
+ aspellDicts.en-science
+ autogen
+ bash-completion
+ bashInteractive
+ beam-environment
+ breezy
+ cacert
+ chromium
+ diffstat
+ diffutils
+ ditaa
+ dnsutils
+ docbook5
+ dos2unix
+ dot2tex
+ duplicity
+ elm-environment
+ emacs-overlay
+ enchant
+ entr
+ exiv2
+ fd
+ ffmpeg
+ file
+ findutils
+ firefox
+ fontconfig
+ fonts-overlay
+ fzf
+ gawk
+ ghc-environment
+ gimp
+ git-tools
+ global
+ gnugrep
+ gnumake
+ gnupg
+ gnuplot
+ gnused
+ gnutar
+ gnutls
+ golang-environment
+ graphviz-nox
+ groff
+ hammer
+ highlight
+ htmlTidy
+ htop
+ httperf
+ imagemagick
+ imgcat
+ inkscape.out
+ iotop
+ isync
+ john
+ jq
+ js-environment
+ jvm-environment11
+ klavaro
+ ledger
+ less
+ libreoffice
+ librsvg
+ mercurial
+ mitmproxy
+ mkpasswd
+ ml-environment
+ mpc_cli
+ mpd
+ msmtp
+ mtr
+ mu
+ ncmpcpp
+ nix-tools
+ nmap
+ notmuch
+ octave
+ openssh
+ openssl
+ openvpn
+ p7zip
+ pandoc
+ paperkey
+ parallel
+ patch
+ patchutils
+ pdftk
+ php-environment
+ plantuml
+ poppler_utils
+ pv
+ pwgen
+ python-environment
+ qrencode
+ r-environment
+ renameutils
+ ripgrep
+ rsync
+ rtags
+ scheme-environment
+ screen
+ shellcheck
+ silver-searcher
+ slack
+ socat
+ sourceHighlight
+ stow
+ subversion
+ svg2tikz
+ tcpdump
+ texFull
+ time
+ tmux
+ tokei
+ tree
+ unzip
+ urlwatch
+ vim
+ w3m
+ watch
+ watchman
+ wavemon
+ wget
+ whois
+ wireshark-qt
+ wordnet
+ xbindkeys
+ wkhtmltopdf
+ xorg.xev
+ xorriso
+ xsensors
+ xsv
+ xz
+ youtube-dl
+ yubikey-personalization
+ zip
+ zoom-us
+ zotero
+ zsh
+ zsh-syntax-highlighting
+]