aboutsummaryrefslogtreecommitdiff
path: root/nix/overlays.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/overlays.nix')
-rw-r--r--nix/overlays.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nix/overlays.nix b/nix/overlays.nix
new file mode 100644
index 00000000..12e0e86d
--- /dev/null
+++ b/nix/overlays.nix
@@ -0,0 +1,14 @@
+{ config, ... }:
+{
+ overlays =
+ let
+ paths = [
+ ./overlays
+ ];
+ in with builtins;
+ concatMap (path:
+ (map (n: import (path + ("/" + n)))
+ (filter (n: match ".*\\.nix" n != null ||
+ pathExists (path + ("/" + n + "/default.nix")))
+ (attrNames (readDir path))))) paths;
+}