aboutsummaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-0.7.7.ebuild
diff options
context:
space:
mode:
authorkballou <kballou@devnulllabs.io>2017-01-20 12:31:49 -0700
committerkballou <kballou@devnulllabs.io>2017-01-20 12:31:49 -0700
commitf2b8cab23b4119dc3fec7c1b3650bb2f77e8c57f (patch)
tree98f76663dfbf95fc3007f455ef120677c4798cc7 /dev-python/Faker/Faker-0.7.7.ebuild
parent6e6a2e26ea20c1bbb61e22bc009ba7db4b3d837d (diff)
downloadfaker-f2b8cab23b4119dc3fec7c1b3650bb2f77e8c57f.tar.gz
faker-f2b8cab23b4119dc3fec7c1b3650bb2f77e8c57f.tar.xz
Add Faker-0.7.7 ebuild
Diffstat (limited to 'dev-python/Faker/Faker-0.7.7.ebuild')
-rw-r--r--dev-python/Faker/Faker-0.7.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-0.7.7.ebuild b/dev-python/Faker/Faker-0.7.7.ebuild
new file mode 100644
index 0000000..e27bb34
--- /dev/null
+++ b/dev-python/Faker/Faker-0.7.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2017 Kenny Ballou
+# Distributed under the terms of the GNU General Public License v3
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+inherit distutils-r1
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Python package for random data generation"
+HOMEPAGE="http://faker.readthedocs.io/en/master/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"