aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Parmer <maxp@trystero.is>2016-03-21 22:22:08 -0700
committerMax Parmer <maxp@trystero.is>2016-03-21 22:22:08 -0700
commit0fd0fa084be615256770251c11e6e4bc948e7456 (patch)
treedcb9bfd0ff55d05fde8a199af996f74505e65557
parent8c735fb356a9e3ff820812aac01ade9aca31e5bf (diff)
downloadprofanity-0fd0fa084be615256770251c11e6e4bc948e7456.tar.gz
profanity-0fd0fa084be615256770251c11e6e4bc948e7456.tar.xz
Adds plugins flag to net-im/profanity-9999, upgrades to EAPI=6
-rw-r--r--net-im/profanity/metadata.xml1
-rw-r--r--net-im/profanity/profanity-9999.ebuild20
2 files changed, 12 insertions, 9 deletions
diff --git a/net-im/profanity/metadata.xml b/net-im/profanity/metadata.xml
index e9c8cf0..01740cf 100644
--- a/net-im/profanity/metadata.xml
+++ b/net-im/profanity/metadata.xml
@@ -10,6 +10,7 @@
<flag name='otr'>Enable Off-the-Record support (encryption)</flag>
<flag name='pgp'>Enable PGP support</flag>
<flag name='themes'>Install additional themes</flag>
+ <flag name='plugins'>Build experimental support for C and Python plugins</flag>
<flag name='xml'>Link with libxml2 instead of expat</flag>
<flag name='xscreensaver'>Use x11-libs/libXScrnSaver for checking idle time</flag>
</use>
diff --git a/net-im/profanity/profanity-9999.ebuild b/net-im/profanity/profanity-9999.ebuild
index 7aba515..3ec7f1d 100644
--- a/net-im/profanity/profanity-9999.ebuild
+++ b/net-im/profanity/profanity-9999.ebuild
@@ -2,42 +2,44 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-EGIT_REPO_URI="git://github.com/boothj5/profanity.git"
-
-inherit autotools git-2
+inherit autotools git-r3
DESCRIPTION="Ncurses based jabber client inspired by irssi"
HOMEPAGE="http://www.profanity.im/"
+EGIT_REPO_URI="https://github.com/boothj5/profanity.git git://github.com/boothj5/profanity.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE="libnotify otr pgp +themes xscreensaver"
+IUSE="libnotify otr pgp plugins +themes xscreensaver"
-RDEPEND=">=dev-libs/glib-2.26:2
+RDEPEND=">=dev-libs/glib-2.26
dev-libs/libmesode
net-misc/curl
- sys-libs/ncurses
- sys-libs/readline
+ sys-libs/ncurses:0
+ sys-libs/readline:0
pgp? ( app-crypt/gpgme )
otr? ( net-libs/libotr )
xscreensaver? ( x11-libs/libXScrnSaver )
libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${P/-/_}"
+S="${WORKDIR}/${P}"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
econf \
+ $(use_enable plugins c-plugins) \
$(use_enable libnotify notifications) \
$(use_enable otr) \
$(use_enable pgp) \
+ $(use_enable plugins python-plugins) \
$(use_with themes) \
$(use_with xscreensaver)
}