aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormegabaks <megagreener@gmail.com>2012-10-08 15:26:58 +0000
committermegabaks <megagreener@gmail.com>2012-10-08 15:26:58 +0000
commit4a19fd7f22ee9c9d7ce938507a8e9ea9e288e7f5 (patch)
tree765976bda2adf0cbbd63165425635f2f9699894f
parent22ea8822e0be6fe564359d7215ec8600558f4874 (diff)
downloadprofanity-4a19fd7f22ee9c9d7ce938507a8e9ea9e288e7f5.tar.gz
profanity-4a19fd7f22ee9c9d7ce938507a8e9ea9e288e7f5.tar.xz
dev-libs/libstrophe
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild32
-rw-r--r--dev-libs/libstrophe/metadata.xml7
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
new file mode 100644
index 0000000..8ef44dc
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/metajack/libstrophe.git"
+
+inherit autotools git-2
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe"
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="xml"
+
+DEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with xml libxml2)
+}
diff --git a/dev-libs/libstrophe/metadata.xml b/dev-libs/libstrophe/metadata.xml
new file mode 100644
index 0000000..eb3996b
--- /dev/null
+++ b/dev-libs/libstrophe/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>megagreener@gmail.com</email>
+ </maintainer>
+</pkgmetadata>