aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2014-03-19 19:46:27 +0200
committerDmitry Podgorny <pasis.ua@gmail.com>2014-03-19 19:46:27 +0200
commit8faf1f24841b8bf55a20e6b5c59dc74fbbf10612 (patch)
tree882304031c5967d26428a0fba6762c1663a23baf
parentacf346594ed0025c41b1adeb305c7497af7b6bad (diff)
downloadprofanity-8faf1f24841b8bf55a20e6b5c59dc74fbbf10612.tar.gz
profanity-8faf1f24841b8bf55a20e6b5c59dc74fbbf10612.tar.xz
net-im/profanity: version 0.4.0-rc1 bump
-rw-r--r--net-im/profanity/profanity-0.4.0_rc1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-im/profanity/profanity-0.4.0_rc1.ebuild b/net-im/profanity/profanity-0.4.0_rc1.ebuild
new file mode 100644
index 0000000..b36a432
--- /dev/null
+++ b/net-im/profanity/profanity-0.4.0_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/boothj5/profanity.git"
+EGIT_COMMIT="0.4.0.rc1"
+
+inherit autotools git-2
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.profanity.im/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify otr xml xscreensaver"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/libstrophe-0.8-r1[xml=]
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/ncurses
+ otr? ( net-libs/libotr )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_with xml libxml2) \
+ $(use_with xscreensaver)
+}
+
+pkg_postinst() {
+ elog
+ elog "User guide is available online:"
+ elog " http://www.profanity.im/userguide.html"
+ elog
+}