aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2014-05-06 13:45:39 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2014-05-06 13:45:39 +0300
commit9945e38dc1fc5e1b329d7c3adfb218f99adfd59d (patch)
treed667244b9827f3f283777d82f2d005fd5083b78e
parentc83bdce98bb5730e98a54fc89d1cff41443422c2 (diff)
downloadprofanity-9945e38dc1fc5e1b329d7c3adfb218f99adfd59d.tar.gz
profanity-9945e38dc1fc5e1b329d7c3adfb218f99adfd59d.tar.xz
dev-libs/libstrophe-9999: fixed build errors
-rw-r--r--dev-libs/libstrophe/files/libstrophe-automake-foreign.patch11
-rw-r--r--dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch20
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild1
3 files changed, 16 insertions, 16 deletions
diff --git a/dev-libs/libstrophe/files/libstrophe-automake-foreign.patch b/dev-libs/libstrophe/files/libstrophe-automake-foreign.patch
new file mode 100644
index 0000000..2027967
--- /dev/null
+++ b/dev-libs/libstrophe/files/libstrophe-automake-foreign.patch
@@ -0,0 +1,11 @@
+diff --git a/configure.ac b/configure.ac
+index a3e48ee..fb123e4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,5 +1,5 @@
+ AC_INIT([libstrophe], [0.8-snapshot], [jack@metajack.im])
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([foreign])
+
+ AC_PROG_CC
+ AC_PROG_RANLIB
diff --git a/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
index 21646cf..2710f4b 100644
--- a/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
+++ b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
@@ -1,8 +1,8 @@
diff --git a/configure.ac b/configure.ac
-index e4f9299..401ded7 100644
+index fb123e4..a9ac211 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -9,21 +9,12 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
+@@ -9,11 +9,9 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
PKG_CHECK_MODULES([check], [check >= 0.9.4], [], [AC_MSG_WARN([libcheck not found; unit tests will not be compilable])])
AC_ARG_WITH([libxml2],
@@ -14,17 +14,5 @@ index e4f9299..401ded7 100644
-if test "x$with_libxml2" != xno; then
+if test "x$with_libxml2" = xyes; then
PKG_CHECK_MODULES([libxml2], [libxml-2.0 >= 2.7],
-- [with_libxml2=yes], [dummy=1])
-- if test "x$with_libxml2" != yes; then
-- old_CFLAGS=$CFLAGS
-- CFLAGS="-I /usr/include/libxml2"
-- AC_CHECK_HEADER([libxml/parser.h],
-- [with_libxml2=yes; libxml2_CFLAGS="-I /usr/include/libxml2"; libxml2_LIBS="-lxml2"],
-- [AC_MSG_ERROR([couldn't find libxml2])])
-- CFLAGS=$old_CFLAGS
-- fi
-+ [with_libxml2=yes],
-+ [AC_MSG_ERROR([couldn't find libxml2])])
- else
- AC_CHECK_HEADER(expat.h, [], [AC_MSG_ERROR([couldn't find expat headers; expat required])])
- fi
+ [with_libxml2=yes], [dummy=1])
+ if test "x$with_libxml2" != xyes; then
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
index 99f5e57..464d055 100644
--- a/dev-libs/libstrophe/libstrophe-9999.ebuild
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/-/_}"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-automake-foreign.patch
epatch "${FILESDIR}"/${PN}-fix-build-libxml2.patch
eautoreconf
}