aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2013-05-19 12:19:23 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2013-05-19 12:19:23 +0300
commit9b8daa68204662a6fb1e7fffde9ee4f7b3927399 (patch)
tree8ebe99f35033517a22d87900e7b95dde242b20f5
parent10da8308f496e8443f8c259735a3f39ab475a7c6 (diff)
downloadprofanity-9b8daa68204662a6fb1e7fffde9ee4f7b3927399.tar.gz
profanity-9b8daa68204662a6fb1e7fffde9ee4f7b3927399.tar.xz
fixed dev-libs/libstrophe-9999
git repo was moved. updated libstrophe-fix-build-libxml2.patch
-rw-r--r--dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch30
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild2
2 files changed, 17 insertions, 15 deletions
diff --git a/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
index 9c90e68..21646cf 100644
--- a/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
+++ b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
@@ -1,18 +1,8 @@
-commit 53cdc96a4b79558a2fb1afb1d388070a5cb8a8f1
-Author: Dmitry Podgorny <pasis.ua@gmail.com>
-Date: Mon Oct 8 12:09:49 2012 +0300
-
- configure.ac: fix building without libxml2
-
- Options --with-libxml2 and --without-libxml2 are broken. libstrophe is
- always built with libxml2 support. This patch fixes the problem and
- makes libstrophe be built with expat support by default.
-
diff --git a/configure.ac b/configure.ac
-index 97444e5..e170fc3 100644
+index e4f9299..401ded7 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -9,11 +9,9 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
+@@ -9,21 +9,12 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
PKG_CHECK_MODULES([check], [check >= 0.9.4], [], [AC_MSG_WARN([libcheck not found; unit tests will not be compilable])])
AC_ARG_WITH([libxml2],
@@ -24,5 +14,17 @@ index 97444e5..e170fc3 100644
-if test "x$with_libxml2" != xno; then
+if test "x$with_libxml2" = xyes; then
PKG_CHECK_MODULES([libxml2], [libxml-2.0 >= 2.7],
- [with_libxml2=yes],
- [AC_MSG_ERROR([couldn't find libxml2])])
+- [with_libxml2=yes], [dummy=1])
+- if test "x$with_libxml2" != yes; then
+- old_CFLAGS=$CFLAGS
+- CFLAGS="-I /usr/include/libxml2"
+- AC_CHECK_HEADER([libxml/parser.h],
+- [with_libxml2=yes; libxml2_CFLAGS="-I /usr/include/libxml2"; libxml2_LIBS="-lxml2"],
+- [AC_MSG_ERROR([couldn't find libxml2])])
+- CFLAGS=$old_CFLAGS
+- fi
++ [with_libxml2=yes],
++ [AC_MSG_ERROR([couldn't find libxml2])])
+ else
+ AC_CHECK_HEADER(expat.h, [], [AC_MSG_ERROR([couldn't find expat headers; expat required])])
+ fi
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
index a687e74..2be6ebb 100644
--- a/dev-libs/libstrophe/libstrophe-9999.ebuild
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-EGIT_REPO_URI="git://github.com/metajack/libstrophe.git"
+EGIT_REPO_URI="git://github.com/strophe/libstrophe.git"
inherit autotools eutils git-2