aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-11 20:23:38 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-11 20:23:38 +0300
commitaf26ba6385d4aaf6254982282b56db54a9e07553 (patch)
tree0a4fa0e873b117c305f3786b489ed2e9d92b9939
parente81eaf98bf59de6b04a0f8aa39669a421cd34b7a (diff)
downloadprofanity-af26ba6385d4aaf6254982282b56db54a9e07553.tar.gz
profanity-af26ba6385d4aaf6254982282b56db54a9e07553.tar.xz
dev-libs/libstrophe: change repo for live build
too many changes must be applied to original repo...
-rw-r--r--dev-libs/libstrophe/files/libstrophe-avoid-null-pointer-dereference.patch25
-rw-r--r--dev-libs/libstrophe/files/libstrophe-build-shared-library.patch61
-rw-r--r--dev-libs/libstrophe/files/libstrophe-handle-zero-buffer.patch13
-rw-r--r--dev-libs/libstrophe/files/libstrophe-libxml2-build-fix.patch18
-rw-r--r--dev-libs/libstrophe/files/libstrophe-pkg-config-support.patch50
-rw-r--r--dev-libs/libstrophe/files/libstrophe-preserve-cflags.patch12
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild8
-rw-r--r--dev-libs/libstrophe/metadata.xml2
8 files changed, 2 insertions, 187 deletions
diff --git a/dev-libs/libstrophe/files/libstrophe-avoid-null-pointer-dereference.patch b/dev-libs/libstrophe/files/libstrophe-avoid-null-pointer-dereference.patch
deleted file mode 100644
index a6c34db..0000000
--- a/dev-libs/libstrophe/files/libstrophe-avoid-null-pointer-dereference.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/src/sasl.c b/src/sasl.c
-index 73fbbc9..6e02414 100644
---- a/src/sasl.c
-+++ b/src/sasl.c
-@@ -494,9 +494,8 @@ unsigned char *base64_decode(xmpp_ctx_t *ctx,
- if (len & 0x03) return NULL;
-
- dlen = base64_decoded_len(ctx, buffer, len);
-- dbuf = xmpp_alloc(ctx, dlen + 1);
-+ d = dbuf = xmpp_alloc(ctx, dlen + 1);
- if (dbuf != NULL) {
-- d = dbuf;
- /* loop over each set of 4 characters, decoding 3 bytes */
- for (i = 0; i < len - 3; i += 4) {
- hextet = _base64_invcharmap[(int)buffer[i]];
-@@ -553,7 +552,8 @@ unsigned char *base64_decode(xmpp_ctx_t *ctx,
- break;
- }
- }
-- *d = '\0';
-+ if (d)
-+ *d = '\0';
- return dbuf;
-
- _base64_decode_error:
diff --git a/dev-libs/libstrophe/files/libstrophe-build-shared-library.patch b/dev-libs/libstrophe/files/libstrophe-build-shared-library.patch
deleted file mode 100644
index 10c9bef..0000000
--- a/dev-libs/libstrophe/files/libstrophe-build-shared-library.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 788d37c..b09ee58 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -6,15 +6,16 @@ PARSER_CFLAGS=@PARSER_CFLAGS@
- PARSER_LIBS=@PARSER_LIBS@
-
- SSL_LIBS = -lssl -lcrypto -lz
-+LIBS += $(SSL_LIBS) $(PARSER_LIBS)
-
- STROPHE_FLAGS = -I$(top_srcdir)
--STROPHE_LIBS = libstrophe.a $(PARSER_LIBS) $(SSL_LIBS)
-+STROPHE_LIBS = libstrophe.la
-
- ## Main build targets
--lib_LIBRARIES = libstrophe.a
-+lib_LTLIBRARIES = libstrophe.la
-
--libstrophe_a_CFLAGS=$(STROPHE_FLAGS) $(PARSER_CFLAGS)
--libstrophe_a_SOURCES = src/auth.c src/conn.c src/ctx.c \
-+libstrophe_la_CFLAGS=$(STROPHE_FLAGS) $(PARSER_CFLAGS)
-+libstrophe_la_SOURCES = src/auth.c src/conn.c src/ctx.c \
- src/event.c src/handler.c src/hash.c \
- src/jid.c src/md5.c src/sasl.c src/sha1.c \
- src/snprintf.c src/sock.c src/stanza.c src/thread.c \
-@@ -23,9 +24,9 @@ libstrophe_a_SOURCES = src/auth.c src/conn.c src/ctx.c \
- src/sasl.h src/sha1.h src/sock.h src/thread.h src/tls.h src/util.h
-
- if PARSER_EXPAT
--libstrophe_a_SOURCES += src/parser_expat.c
-+libstrophe_la_SOURCES += src/parser_expat.c
- else
--libstrophe_a_SOURCES += src/parser_libxml2.c
-+libstrophe_la_SOURCES += src/parser_libxml2.c
- endif
-
- include_HEADERS = strophe.h
-diff --git a/bootstrap.sh b/bootstrap.sh
-index 473f746..3b72d88 100755
---- a/bootstrap.sh
-+++ b/bootstrap.sh
-@@ -5,6 +5,7 @@ if [ -d /usr/local/share/aclocal ]; then
- ACFLAGS="-I /usr/local/share/aclocal"
- fi
-
-+libtoolize
- aclocal ${ACFLAGS}
- automake --add-missing --foreign --copy
- autoconf
-diff --git a/configure.ac b/configure.ac
-index e170fc3..9ad2c1b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -3,6 +3,7 @@ AM_INIT_AUTOMAKE
-
- AC_PROG_CC
- AC_PROG_RANLIB
-+AC_PROG_LIBTOOL
- AM_PROG_CC_C_O
-
- AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers, openssl required])])
diff --git a/dev-libs/libstrophe/files/libstrophe-handle-zero-buffer.patch b/dev-libs/libstrophe/files/libstrophe-handle-zero-buffer.patch
deleted file mode 100644
index 20d278d..0000000
--- a/dev-libs/libstrophe/files/libstrophe-handle-zero-buffer.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/sasl.c b/src/sasl.c
-index 6e02414..cc70a6b 100644
---- a/src/sasl.c
-+++ b/src/sasl.c
-@@ -490,6 +490,8 @@ unsigned char *base64_decode(xmpp_ctx_t *ctx,
- uint32_t word, hextet;
- int i;
-
-+ /* handle zero-length buffers */
-+ if (!len) return NULL;
- /* len must be a multiple of 4 */
- if (len & 0x03) return NULL;
-
diff --git a/dev-libs/libstrophe/files/libstrophe-libxml2-build-fix.patch b/dev-libs/libstrophe/files/libstrophe-libxml2-build-fix.patch
deleted file mode 100644
index c7d6757..0000000
--- a/dev-libs/libstrophe/files/libstrophe-libxml2-build-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 97444e5..e170fc3 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -9,11 +9,9 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
- PKG_CHECK_MODULES([check], [check >= 0.9.4], [], [AC_MSG_WARN([libcheck not found; unit tests will not be compilable])])
-
- AC_ARG_WITH([libxml2],
-- [AS_HELP_STRING([--with-libxml2], [use libxml2 for XML parsing])],
-- [with_libxml2=check],
-- [with_libxml2=no])
-+ [AS_HELP_STRING([--with-libxml2], [use libxml2 for XML parsing])])
-
--if test "x$with_libxml2" != xno; then
-+if test "x$with_libxml2" = xyes; then
- PKG_CHECK_MODULES([libxml2], [libxml-2.0 >= 2.7],
- [with_libxml2=yes],
- [AC_MSG_ERROR([couldn't find libxml2])])
diff --git a/dev-libs/libstrophe/files/libstrophe-pkg-config-support.patch b/dev-libs/libstrophe/files/libstrophe-pkg-config-support.patch
deleted file mode 100644
index db16f0d..0000000
--- a/dev-libs/libstrophe/files/libstrophe-pkg-config-support.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index b09ee58..d6c534e 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,6 +2,8 @@ AUTOMAKE_OPTIONS = subdir-objects
-
- CFLAGS = -g -Wall
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+
- PARSER_CFLAGS=@PARSER_CFLAGS@
- PARSER_LIBS=@PARSER_LIBS@
-
-@@ -34,6 +36,8 @@ noinst_HEADERS = strophepp.h
-
- EXTRA_DIST = docs
-
-+pkgconfig_DATA = libstrophe.pc
-+
- ## Examples
- noinst_PROGRAMS = examples/active examples/roster examples/basic examples/bot
- examples_active_SOURCES = examples/active.c
-diff --git a/configure.ac b/configure.ac
-index 9ad2c1b..1496990 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -43,5 +43,5 @@ AM_CONDITIONAL([PARSER_EXPAT], [test x$with_parser != xlibxml2])
- AC_SUBST(PARSER_NAME)
- AC_SUBST(PARSER_CFLAGS)
- AC_SUBST(PARSER_LIBS)
--AC_CONFIG_FILES([Makefile])
-+AC_CONFIG_FILES([Makefile libstrophe.pc])
- AC_OUTPUT
-diff --git a/libstrophe.pc.in b/libstrophe.pc.in
-new file mode 100644
-index 0000000..9ab13d4
---- /dev/null
-+++ b/libstrophe.pc.in
-@@ -0,0 +1,11 @@
-+prefix=@prefix@
-+exec_prefix=@exec_prefix@
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: libstrophe
-+Description: A simple, lightweight C library for writing XMPP clients
-+Requires:
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lstrophe
-+Cflags: -I${includedir}
diff --git a/dev-libs/libstrophe/files/libstrophe-preserve-cflags.patch b/dev-libs/libstrophe/files/libstrophe-preserve-cflags.patch
deleted file mode 100644
index 922571f..0000000
--- a/dev-libs/libstrophe/files/libstrophe-preserve-cflags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index d6c534e..0a1a12f 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,6 +1,6 @@
- AUTOMAKE_OPTIONS = subdir-objects
-
--CFLAGS = -g -Wall
-+CFLAGS += -g -Wall
-
- pkgconfigdir = $(libdir)/pkgconfig
-
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
index 4b59d1b..578ebab 100644
--- a/dev-libs/libstrophe/libstrophe-9999.ebuild
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-EGIT_REPO_URI="git://github.com/metajack/libstrophe.git"
+EGIT_REPO_URI="git://github.com/pasis/libstrophe.git"
inherit libtool autotools eutils git-2
@@ -25,12 +25,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/-/_}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-libxml2-build-fix.patch
- epatch "${FILESDIR}"/${PN}-build-shared-library.patch
- epatch "${FILESDIR}"/${PN}-pkg-config-support.patch
- epatch "${FILESDIR}"/${PN}-preserve-cflags.patch
- epatch "${FILESDIR}"/${PN}-avoid-null-pointer-dereference.patch
- epatch "${FILESDIR}"/${PN}-handle-zero-buffer.patch
elibtoolize
eautoreconf
}
diff --git a/dev-libs/libstrophe/metadata.xml b/dev-libs/libstrophe/metadata.xml
index ea4583c..9e37ade 100644
--- a/dev-libs/libstrophe/metadata.xml
+++ b/dev-libs/libstrophe/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>megagreener@gmail.com</email>
+ <email>pasis.ua@gmail.com</email>
</maintainer>
<use>
<flag name='xml'>Use dev-libs/libxml2 to parse XML</flag>