aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.8.ebuild
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-25 00:46:34 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-25 00:46:34 +0300
commit509791f433bf79cd06bb53a5f6c73ebebe761756 (patch)
tree97a1e1a85c5bc92d9525d3d73a147a2e17677308 /dev-libs/libstrophe/libstrophe-0.8.ebuild
parent3e6412bea0e3a8a1c5d0dd56bd47d280083b9abd (diff)
downloadprofanity-509791f433bf79cd06bb53a5f6c73ebebe761756.tar.gz
profanity-509791f433bf79cd06bb53a5f6c73ebebe761756.tar.xz
dev-libs/libstrophe-0.8 add patch from upstream
The patch adds option for disabling TLS. This makes various programs compile with current version of library.
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.8.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.8.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.8.ebuild b/dev-libs/libstrophe/libstrophe-0.8.ebuild
index d3debc9..3f7ecc1 100644
--- a/dev-libs/libstrophe/libstrophe-0.8.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.8.ebuild
@@ -4,6 +4,8 @@
EAPI=4
+inherit eutils
+
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="http://strophe.im/libstrophe/"
SRC_URI="https://github.com/downloads/metajack/${PN}/${P}-snapshot.tar.gz"
@@ -21,6 +23,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}-snapshot"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-xmpp-conn-disable-tls.patch
+}
+
src_configure() {
use xml && econf $(use_with xml libxml2)
# workaround for building with expat support