aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.8.ebuild
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-23 17:51:20 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-23 17:51:20 +0300
commit698130088a6def93e3073b679a8181464360b40d (patch)
tree0c53d198637b32e418cfecc4c0d64657fffe1b6c /dev-libs/libstrophe/libstrophe-0.8.ebuild
parent7ea9829c0cf6088dae11a225e7ec77364a78bbef (diff)
downloadprofanity-698130088a6def93e3073b679a8181464360b40d.tar.gz
profanity-698130088a6def93e3073b679a8181464360b40d.tar.xz
dev-libs/libstrophe-0.8 version bump
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.8.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.8.ebuild b/dev-libs/libstrophe/libstrophe-0.8.ebuild
new file mode 100644
index 0000000..d3debc9
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/downloads/metajack/${PN}/${P}-snapshot.tar.gz"
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${P}-snapshot"
+
+src_configure() {
+ use xml && econf $(use_with xml libxml2)
+ # workaround for building with expat support
+ use xml || econf
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ einstall
+ use doc && dohtml -r docs/html/*
+}