aboutsummaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-16 16:13:47 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-16 16:13:47 +0300
commitbb8015b8d6c91294df433de098b30063194d7bb8 (patch)
treef2c487e51e1d377daf09ec2f6f4f1f01965afec4 /dev-libs
parentf78aa23b1c61c887366ec4a5575998d84a30e2f4 (diff)
downloadprofanity-bb8015b8d6c91294df433de098b30063194d7bb8.tar.gz
profanity-bb8015b8d6c91294df433de098b30063194d7bb8.tar.xz
net-im/profanity
add net-im/profanity-9999 add also dev-libs/libstrophe as dependency
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch28
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild47
-rw-r--r--dev-libs/libstrophe/metadata.xml11
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
new file mode 100644
index 0000000..9c90e68
--- /dev/null
+++ b/dev-libs/libstrophe/files/libstrophe-fix-build-libxml2.patch
@@ -0,0 +1,28 @@
+commit 53cdc96a4b79558a2fb1afb1d388070a5cb8a8f1
+Author: Dmitry Podgorny <pasis.ua@gmail.com>
+Date: Mon Oct 8 12:09:49 2012 +0300
+
+ configure.ac: fix building without libxml2
+
+ Options --with-libxml2 and --without-libxml2 are broken. libstrophe is
+ always built with libxml2 support. This patch fixes the problem and
+ makes libstrophe be built with expat support by default.
+
+diff --git a/configure.ac b/configure.ac
+index 97444e5..e170fc3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,11 +9,9 @@ AC_CHECK_HEADER(openssl/ssl.h, [], [AC_MSG_ERROR([couldn't find openssl headers,
+ PKG_CHECK_MODULES([check], [check >= 0.9.4], [], [AC_MSG_WARN([libcheck not found; unit tests will not be compilable])])
+
+ AC_ARG_WITH([libxml2],
+- [AS_HELP_STRING([--with-libxml2], [use libxml2 for XML parsing])],
+- [with_libxml2=check],
+- [with_libxml2=no])
++ [AS_HELP_STRING([--with-libxml2], [use libxml2 for XML parsing])])
+
+-if test "x$with_libxml2" != xno; then
++if test "x$with_libxml2" = xyes; then
+ PKG_CHECK_MODULES([libxml2], [libxml-2.0 >= 2.7],
+ [with_libxml2=yes],
+ [AC_MSG_ERROR([couldn't find libxml2])])
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
new file mode 100644
index 0000000..28b42d6
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/metajack/libstrophe.git"
+
+inherit autotools eutils git-2
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE=""
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-fix-build-libxml2.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with xml libxml2)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ einstall
+ dodoc LICENSE.txt README.markdown
+ use doc && dohtml -r docs/html/*
+}
diff --git a/dev-libs/libstrophe/metadata.xml b/dev-libs/libstrophe/metadata.xml
new file mode 100644
index 0000000..4edd917
--- /dev/null
+++ b/dev-libs/libstrophe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pasis.ua@gmail.com</email>
+ <name>Dmitry Podgorny</name>
+ </maintainer>
+ <use>
+ <flag name='xml'>Use dev-libs/libxml2 to parse XML</flag>
+ </use>
+</pkgmetadata>