aboutsummaryrefslogtreecommitdiff
path: root/net-im/profanity/profanity-0.5.0.ebuild
diff options
context:
space:
mode:
authorkballou <kballou@devnulllabs.io>2016-09-20 19:43:51 -0600
committerkballou <kballou@devnulllabs.io>2016-09-23 10:09:19 -0600
commitdd1c2f99739147ab560bf2a9c3f722e86f7ad6a7 (patch)
tree250325b196637062648c27080df30161b89fb8a3 /net-im/profanity/profanity-0.5.0.ebuild
parent6a2062f29aaf0c2bfa374fed3d512227abe9eb2d (diff)
downloadprofanity-dd1c2f99739147ab560bf2a9c3f722e86f7ad6a7.tar.gz
profanity-dd1c2f99739147ab560bf2a9c3f722e86f7ad6a7.tar.xz
Update profanity to 0.5.0
Updated to new release of [profanity][1]. [1]: https://github.com/boothj5/profanity/blob/0.5.0/CHANGELOG
Diffstat (limited to 'net-im/profanity/profanity-0.5.0.ebuild')
-rw-r--r--net-im/profanity/profanity-0.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-im/profanity/profanity-0.5.0.ebuild b/net-im/profanity/profanity-0.5.0.ebuild
new file mode 100644
index 0000000..80951bf
--- /dev/null
+++ b/net-im/profanity/profanity-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.profanity.im/"
+SRC_URI="http://www.profanity.im/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify otr pgp +themes xml xscreensaver"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=dev-libs/libstrophe-0.9.1[xml=]
+ net-misc/curl
+ sys-libs/ncurses
+ sys-libs/readline
+ pgp? ( app-crypt/gpgme )
+ otr? ( net-libs/libotr )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable pgp) \
+ $(use_with themes) \
+ $(use_with xml libxml2) \
+ $(use_with xscreensaver)
+}
+
+pkg_postinst() {
+ elog
+ elog "User guide is available online:"
+ elog " http://www.profanity.im/userguide.html"
+ elog
+}