aboutsummaryrefslogtreecommitdiff
path: root/net-im/profanity/profanity-9999.ebuild
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-16 16:13:47 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-16 16:13:47 +0300
commitbb8015b8d6c91294df433de098b30063194d7bb8 (patch)
treef2c487e51e1d377daf09ec2f6f4f1f01965afec4 /net-im/profanity/profanity-9999.ebuild
parentf78aa23b1c61c887366ec4a5575998d84a30e2f4 (diff)
downloadprofanity-bb8015b8d6c91294df433de098b30063194d7bb8.tar.gz
profanity-bb8015b8d6c91294df433de098b30063194d7bb8.tar.xz
net-im/profanity
add net-im/profanity-9999 add also dev-libs/libstrophe as dependency
Diffstat (limited to 'net-im/profanity/profanity-9999.ebuild')
-rw-r--r--net-im/profanity/profanity-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-im/profanity/profanity-9999.ebuild b/net-im/profanity/profanity-9999.ebuild
new file mode 100644
index 0000000..48865db
--- /dev/null
+++ b/net-im/profanity/profanity-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/boothj5/profanity.git"
+
+inherit autotools git-2
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.boothj5.com/profanity.shtml"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="libnotify"
+
+RDEPEND="dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libstrophe
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/ncurses
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ eautoreconf
+}