aboutsummaryrefslogtreecommitdiff
path: root/net-im/profanity
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-25 00:52:20 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-25 00:52:20 +0300
commit94aaa3088444efb0f36289086c2a7f0cd9f7b43a (patch)
tree2b55d7363e8d4f1a260574d84f93d4bfea69dad4 /net-im/profanity
parent509791f433bf79cd06bb53a5f6c73ebebe761756 (diff)
downloadprofanity-94aaa3088444efb0f36289086c2a7f0cd9f7b43a.tar.gz
profanity-94aaa3088444efb0f36289086c2a7f0cd9f7b43a.tar.xz
net-im/profanity-0.1.9 version bump
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.1.9.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index ee1a1fd..c5b8cdd 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1,2 @@
DIST profanity-0.1.8.tar.gz 49400 SHA256 9178d63da7a78ac8f29e90d8171dff9982015e865afdfef2e3333f2592f98d47 SHA512 c5caa33da61125877aec38a7ae4ced33649a65d90eae9b72dcf8077fca5dee990cf06c989924bec79bee4af71464897530effcf39d5f6f8327c0ed283a205ef7 WHIRLPOOL a4a9e2874ab2b43d39b8b7495287404641b70a91928f1ffd85a88b19b77cdbaff0001dbd53473f6e92b0e5fc19ab2f106496d7dff5627dfa53ad62be810a705e
+DIST profanity-0.1.9.tar.gz 54791 SHA256 9fdc1702248ad0e74ccb09ca1e919c37746d67ec57261613d61a42fe04fe0936 SHA512 a74a5785fbbd8c12c1745c6ed94f06d5e4a85ba4aea781ec80e21a01f8560c89ca1553ae1776fb05d96d9d984fa2c6568f735220688224d6e0c87df6ae8fb2ed WHIRLPOOL 44041d098d38dba791a53b0efc9bd9e769ac2060fd01505cc84f2cef0ad31c28ce49215ee4b9cc2de6ef65c11f00e29961645d8250a69492830bb2e5f6c3f6c0
diff --git a/net-im/profanity/profanity-0.1.9.ebuild b/net-im/profanity/profanity-0.1.9.ebuild
new file mode 100644
index 0000000..79185b5
--- /dev/null
+++ b/net-im/profanity/profanity-0.1.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.boothj5.com/profanity.shtml"
+SRC_URI="https://github.com/downloads/boothj5/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify xml"
+
+RDEPEND="dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libstrophe[xml=]
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/ncurses
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with xml libxml2)
+}