aboutsummaryrefslogtreecommitdiff
path: root/net-im/profanity
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2013-03-20 22:23:08 +0200
committerDmitry Podgorny <pasis.ua@gmail.com>2013-03-20 22:23:08 +0200
commitffe7c06bc54d5b158bd0bb8fc1e304a7a0e8296d (patch)
tree641294f82eabbe0375bd0df950a4c4c8e7be9c57 /net-im/profanity
parent1de8394af62bac1e4e0354267b949c1187ea3d2c (diff)
downloadprofanity-ffe7c06bc54d5b158bd0bb8fc1e304a7a0e8296d.tar.gz
profanity-ffe7c06bc54d5b158bd0bb8fc1e304a7a0e8296d.tar.xz
net-im/profanity: version bumped to 0.2.1
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest2
-rw-r--r--net-im/profanity/files/profanity-0.2.0-fix-strdup.patch45
-rw-r--r--net-im/profanity/profanity-0.2.1.ebuild (renamed from net-im/profanity/profanity-0.2.0.ebuild)8
3 files changed, 2 insertions, 53 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index a14e34c..351d03e 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1 @@
-DIST profanity-0.2.0.tar.gz 319651 SHA256 d2f81451870d88ed7d18ba2805de50c8748ca4f21e8b61c8cba927200c01948b SHA512 cd332ce2fdfb135d01deb1e3fb3c1e4de85e47b6857db0b2d12f981221e00b1a201e17cf314618f657baf6587ef1ac2728cc08d51affad2111d64b6b2846390c WHIRLPOOL 085e37ae51d1832ca97474919e93858afdb6f53f0089c1ff603a8f7b136cc7ba48b8ac9fe1ecb6023d0b166349b646aaef128e534f239a1c0825a17fdfe77e3e
+DIST profanity-0.2.1.tar.gz 319746 SHA256 fa1e1c568bb3563bfd0ab767664bd0574c3c2875616fc2a88f71eacee87c8579 SHA512 05d6fce6169a5da9e98ffb15240e7a86b0e8ede51ca0c8f69896b8d8f5d8903486e5aeb303b1ae3ad46396c180dfc35632875c4a45667d426c5806bfa5f02e82 WHIRLPOOL 9ef430985e8d3e1706d72da1645532992db5560d766c4215d1060c3a26d0987176779a302596a47a1fd6b0a47d160a26a930b2dd54939f8f16881518298bea81
diff --git a/net-im/profanity/files/profanity-0.2.0-fix-strdup.patch b/net-im/profanity/files/profanity-0.2.0-fix-strdup.patch
deleted file mode 100644
index b36db3a..0000000
--- a/net-im/profanity/files/profanity-0.2.0-fix-strdup.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/src/xmpp/connection.h b/src/xmpp/connection.h
-index 3c0c1bf..b570125 100644
---- a/src/xmpp/connection.h
-+++ b/src/xmpp/connection.h
-@@ -25,6 +25,8 @@
-
- #include <strophe.h>
-
-+#include "resource.h"
-+
- xmpp_conn_t *connection_get_conn(void);
- xmpp_ctx_t *connection_get_ctx(void);
- int connection_error_handler(xmpp_conn_t * const conn,
-diff --git a/src/xmpp/stanza.c b/src/xmpp/stanza.c
-index 8e02343..4ee3bad 100644
---- a/src/xmpp/stanza.c
-+++ b/src/xmpp/stanza.c
-@@ -27,6 +27,7 @@
- #include <strophe.h>
-
- #include "common.h"
-+#include "xmpp/connection.h"
- #include "xmpp/stanza.h"
- #include "xmpp/capabilities.h"
-
-@@ -562,6 +563,7 @@ DataForm *
- stanza_create_form(xmpp_stanza_t * const stanza)
- {
- DataForm *result = NULL;
-+ xmpp_ctx_t *ctx = connection_get_ctx();
-
- xmpp_stanza_t *child = xmpp_stanza_get_children(stanza);
-
-@@ -591,7 +593,10 @@ stanza_create_form(xmpp_stanza_t * const stanza)
- // handle values
- while (value != NULL) {
- char *text = xmpp_stanza_get_text(value);
-- field->values = g_slist_insert_sorted(field->values, strdup(text), (GCompareFunc)octet_compare);
-+ if (text != NULL) {
-+ field->values = g_slist_insert_sorted(field->values, strdup(text), (GCompareFunc)octet_compare);
-+ xmpp_free(ctx, text);
-+ }
- value = xmpp_stanza_get_next(value);
- }
-
diff --git a/net-im/profanity/profanity-0.2.0.ebuild b/net-im/profanity/profanity-0.2.1.ebuild
index c1060b2..9a8f3b2 100644
--- a/net-im/profanity/profanity-0.2.0.ebuild
+++ b/net-im/profanity/profanity-0.2.1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
-inherit eutils
-
DESCRIPTION="Ncurses based jabber client inspired by irssi"
HOMEPAGE="http://www.profanity.im/"
SRC_URI="http://www.profanity.im/${P}.tar.gz"
@@ -24,10 +22,6 @@ RDEPEND="dev-libs/glib:2
libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fix-strdup.patch
-}
-
src_configure() {
econf $(use_with xml libxml2)
}