aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/profanity/Manifest2
-rw-r--r--net-im/profanity/files/profanity-fix-libstrophe-check.patch50
-rw-r--r--net-im/profanity/profanity-0.4.4.ebuild (renamed from net-im/profanity/profanity-0.4.2.ebuild)10
3 files changed, 58 insertions, 4 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index bcf4b7b..c356fe9 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1 @@
-DIST profanity-0.4.2.tar.gz 426043 SHA256 9b65095a6bf971c423d7512433fcae95c25f2de1355fbd6d8e4794a9c72c9021 SHA512 4d1c78d6b5beaf6627cf82c2ca572fa89027cb56db5eb65d421fd6ab7b8653650d99006c88bf77713dbbc02a6da6755b6a1edd8450a210819ddcd8e07eb7c57e WHIRLPOOL 1ce1ab4465e08f9557e2e87c4e57284f8820a6ced8635ff6cd5e5a4fc55f35629ab067dd0fe376117a4c3557e97178c140a397ec7574d5d194ce85ab59795709
+DIST profanity-0.4.4.tar.gz 384555 SHA256 2fafc730702dc5254244ee7c0dbbfed600ffe9d27afd095b32e28500754cca4d SHA512 3d5556885cb4a97162faa84cb7f9f5c6657a804d9a8ec71829428780fda8548b8e3ecb6b6005fd3db35b2f250bc8d2ca338af0ba1321ca6ac163b90716a66c5a WHIRLPOOL 2cf4c5ddd4131f258c54346211610f83c91bac57c4d40dfe4b9a65f2a14bbfc5a4dd2b26791ac5908859f6e525e1c4a8ca3db25dd42fddef2aa7937940bdce2e
diff --git a/net-im/profanity/files/profanity-fix-libstrophe-check.patch b/net-im/profanity/files/profanity-fix-libstrophe-check.patch
new file mode 100644
index 0000000..e408cc2
--- /dev/null
+++ b/net-im/profanity/files/profanity-fix-libstrophe-check.patch
@@ -0,0 +1,50 @@
+--- a/configure 2014-08-25 00:30:09.000000000 +0300
++++ b/configure 2014-09-07 15:01:08.948292323 +0300
+@@ -4601,9 +4601,9 @@
+ # TODO: autodetect of XML parser libstrophe linked with
+ CFLAGS_RESTORE="$CFLAGS"
+ CFLAGS="$CFLAGS $AM_CPPFLAGS"
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for parser_new in -lstrophe" >&5
+-$as_echo_n "checking for parser_new in -lstrophe... " >&6; }
+-if ${ac_cv_lib_strophe_parser_new+:} false; then :
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for xmpp_ctx_new in -lstrophe" >&5
++$as_echo_n "checking for xmpp_ctx_new in -lstrophe... " >&6; }
++if ${ac_cv_lib_strophe_xmpp_ctx_new+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+@@ -4617,27 +4617,27 @@
+ #ifdef __cplusplus
+ extern "C"
+ #endif
+-char parser_new ();
++char xmpp_ctx_new ();
+ int
+ main ()
+ {
+-return parser_new ();
++return xmpp_ctx_new ();
+ ;
+ return 0;
+ }
+ _ACEOF
+ if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_lib_strophe_parser_new=yes
++ ac_cv_lib_strophe_xmpp_ctx_new=yes
+ else
+- ac_cv_lib_strophe_parser_new=no
++ ac_cv_lib_strophe_xmpp_ctx_new=no
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_strophe_parser_new" >&5
+-$as_echo "$ac_cv_lib_strophe_parser_new" >&6; }
+-if test "x$ac_cv_lib_strophe_parser_new" = xyes; then :
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_strophe_xmpp_ctx_new" >&5
++$as_echo "$ac_cv_lib_strophe_xmpp_ctx_new" >&6; }
++if test "x$ac_cv_lib_strophe_xmpp_ctx_new" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+ #define HAVE_LIBSTROPHE 1
+ _ACEOF
diff --git a/net-im/profanity/profanity-0.4.2.ebuild b/net-im/profanity/profanity-0.4.4.ebuild
index 7cc0a2b..55226d6 100644
--- a/net-im/profanity/profanity-0.4.2.ebuild
+++ b/net-im/profanity/profanity-0.4.4.ebuild
@@ -4,6 +4,8 @@
EAPI=4
+inherit eutils
+
DESCRIPTION="Ncurses based jabber client inspired by irssi"
HOMEPAGE="http://www.profanity.im/"
SRC_URI="http://www.profanity.im/${P}.tar.gz"
@@ -13,10 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libnotify otr +themes xml xscreensaver"
-RDEPEND="dev-libs/glib:2
+RDEPEND=">=dev-libs/glib-2.26:2
>=dev-libs/libstrophe-0.8-r1[xml=]
- dev-libs/openssl
- >=net-libs/gnutls-2.8.0
net-misc/curl
sys-libs/ncurses
otr? ( net-libs/libotr )
@@ -24,6 +24,10 @@ RDEPEND="dev-libs/glib:2
libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-fix-libstrophe-check.patch
+}
+
src_configure() {
econf \
$(use_enable libnotify notifications) \