aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.1.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
new file mode 100644
index 0000000..ee1a1fd
--- /dev/null
+++ b/net-im/profanity/Manifest
@@ -0,0 +1 @@
+DIST profanity-0.1.8.tar.gz 49400 SHA256 9178d63da7a78ac8f29e90d8171dff9982015e865afdfef2e3333f2592f98d47 SHA512 c5caa33da61125877aec38a7ae4ced33649a65d90eae9b72dcf8077fca5dee990cf06c989924bec79bee4af71464897530effcf39d5f6f8327c0ed283a205ef7 WHIRLPOOL a4a9e2874ab2b43d39b8b7495287404641b70a91928f1ffd85a88b19b77cdbaff0001dbd53473f6e92b0e5fc19ab2f106496d7dff5627dfa53ad62be810a705e
diff --git a/net-im/profanity/profanity-0.1.8.ebuild b/net-im/profanity/profanity-0.1.8.ebuild
new file mode 100644
index 0000000..a7b740b
--- /dev/null
+++ b/net-im/profanity/profanity-0.1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.boothj5.com/profanity.shtml"
+SRC_URI="https://github.com/downloads/boothj5/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libstrophe
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/ncurses
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}