aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.8.8.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.8.8.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.8.8.ebuild b/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
index 1f85e36..067f348 100644
--- a/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="http://strophe.im/libstrophe/"
@@ -22,19 +22,24 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
- use xml && econf $(use_with xml libxml2)
- # workaround for building with expat support
- use xml || econf
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
+}
+src_compile() {
+ emake
+ use doc && doxygen
}
src_install() {
emake DESTDIR="${D}" install
- if use doc; then
- doxygen || die
- fi
- use doc && dohtml -r docs/html/*
+ use doc && dodoc -r docs/html
}