aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.9.1.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.9.1.ebuild b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
new file mode 100644
index 0000000..067f348
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
+}
+src_compile() {
+ emake
+ use doc && doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc -r docs/html
+}