summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkennyballou <kballou@onyx.boisestate.edu>2012-10-26 00:09:04 -0600
committerkballou <kballou@onyx.boisestate.edu>2012-10-26 00:09:04 -0600
commit1a275117ca0f10a8efa6a80291eaf3c912924d49 (patch)
tree66bc071b71e5c0000850f6efb580fe704b5b186a /setup.py
parent8a9d577ac7c32928b76bc4193e241eef5bc30126 (diff)
downloadxnt-1a275117ca0f10a8efa6a80291eaf3c912924d49.tar.gz
xnt-1a275117ca0f10a8efa6a80291eaf3c912924d49.tar.xz
Add license preamle/ headers to all ``.py`` files
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2fee87d..c94944e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,21 @@
#!/usr/bin/env python
+# Xnt -- A Wrapper Build Tool
+# Copyright (C) 2012 Kenny Ballou
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
import os
import shutil
from setuptools import setup, find_packages