summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkennyballou <kballou@onyx.boisestate.edu>2012-10-16 13:13:14 -0600
committerkballou <kballou@onyx.boisestate.edu>2012-10-16 13:13:14 -0600
commit1eb7aadf1de66350ebcad5e8ea54adf6a0aa2a33 (patch)
treeb0b5271ea05ea0ff0f07e673f5935ebdbf0750da /setup.py
parente9fd27d8bc130a7e51937b8fb0fe39b2d2a4d014 (diff)
downloadxnt-1eb7aadf1de66350ebcad5e8ea54adf6a0aa2a33.tar.gz
xnt-1eb7aadf1de66350ebcad5e8ea54adf6a0aa2a33.tar.xz
Add windows support
Windows was having issues finding the entry_points and some other implementation ideas were having package including conflicts. Update MANIFEST.in, there are no longer any root `py` files to include.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index a2053f8..d708754 100644
--- a/setup.py
+++ b/setup.py
@@ -17,14 +17,14 @@ setup(
license="gpl3",
keywords="Build Scripts",
packages=find_packages(),
- scripts=["Xnt.py",],
+ scripts=["xnt/xenant.py",],
package_data={
},
long_description=read("README.markdown"),
- platforms=["Linux",],
+ platforms=["Linux", "Windows",],
entry_points={
'console_scripts': [
- 'xnt = Xnt:main',
+ 'xnt = xnt.xenant:main',
],
},
)