summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkennyballou <kballou@onyx.boisestate.edu>2012-10-22 14:11:16 -0600
committerkballou <kballou@onyx.boisestate.edu>2012-10-22 14:11:16 -0600
commit5530193fd41e71bae159ba8c3e1c4fc6842d95f1 (patch)
tree1fc1e7c6dcaf28d0c94c768f31f413daccfcdea1 /setup.py
parent7e2e7ce27a9e4af8f6cea59a7de6002f216e8d31 (diff)
downloadxnt-5530193fd41e71bae159ba8c3e1c4fc6842d95f1.tar.gz
xnt-5530193fd41e71bae159ba8c3e1c4fc6842d95f1.tar.xz
Remove (depricated) options, add classifiers
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 05d5584..69ff631 100644
--- a/setup.py
+++ b/setup.py
@@ -14,8 +14,6 @@ setup(
author_email="kennethmgballou@gmail.com",
url="https://bitbucket.org/devnulltao/xnt",
description=("High-Level build script for doing more complex build tasks"),
- license="gpl3",
- keywords="Build Scripts",
packages=find_packages(),
scripts=["xnt/xenant.py",],
package_data={
@@ -28,4 +26,16 @@ setup(
],
},
install_requires=['distribute',],
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Natural Language :: English',
+ 'Operating System :: Microsoft :: Windows :: Windows 7',
+ 'Operating System :: POSIX :: Linux',
+ 'Topic :: Software Development',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Utilities',
+ ],
)