summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkennyballou <kballou@onyx.boisestate.edu>2013-03-01 21:12:54 -0700
committerkennyballou <kballou@onyx.boisestate.edu>2013-03-01 21:12:54 -0700
commit69a4577f44cd3b5a2be63832ad7e9b247469862c (patch)
treea615f5d8b8d5db1362e533d716d45f2748765133 /setup.py
parent5a440ae9c9f759bf08528de81d0dc815ac05605a (diff)
downloadxnt-69a4577f44cd3b5a2be63832ad7e9b247469862c.tar.gz
xnt-69a4577f44cd3b5a2be63832ad7e9b247469862c.tar.xz
Refactor Versioning
Xnt now has a version module that all other modules shall use when requesting version information
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a7f95b5..7002997 100644
--- a/setup.py
+++ b/setup.py
@@ -20,12 +20,17 @@ import os
import shutil
from setuptools import setup, find_packages
+xnt_version = os.path.join(os.path.abspath(
+ os.path.dirname(__file__)), 'xnt', 'version.py')
+
+exec(compile(open(xnt_version).read(), xnt_version, 'exec'))
+
def read(fname):
return "\n" + open(os.path.join(os.path.dirname(__file__), fname)).read()
setup(
name="Xnt",
- version="0.5.0",
+ version=__version__,
author="Kenny Ballou",
author_email="kennethmgballou@gmail.com",
url="https://github.com/devnulltao/Xnt",