summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-22 23:39:55 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:19 -0400
commit24487f2ddc2e2a4cc1bd6062d1eb10ec518fcaa2 (patch)
tree0fa8822bd22e174ce1061f803b8f06c16a4412a1
parentfb138d367c7ba5b22efc28ce60a8e103250b808a (diff)
downloadguix-24487f2ddc2e2a4cc1bd6062d1eb10ec518fcaa2.tar.gz
guix-24487f2ddc2e2a4cc1bd6062d1eb10ec518fcaa2.tar.xz
gnu: Add go-github-com-keybase-go-ps.
* gnu/packages/golang.scm (go-github-com-keybase-go-ps): New variable.
-rw-r--r--gnu/packages/golang.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a531715ab9..ad90ac4473 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,44 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-keybase-go-ps
+ (let ((commit "91aafc93ba19d1988cff338c1929d35b6c6f5b50")
+ (revision "0"))
+ (package
+ (name "go-github-com-keybase-go-ps")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/keybase/go-ps")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1la7m9pd1rrij727g34k9d2iapqwrkwdkqwpkbsbcq8ig0fg634h"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/keybase/go-ps"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (substitute* (find-files "." "test\\.go")
+ (("/bin/sleep" command)
+ (string-append
+ (assoc-ref (or native-inputs inputs) "coreutils")
+ command))))))))
+ (native-inputs
+ `(("coreutils" ,coreutils)
+ ("go-github-com-stretchr-testify"
+ ,go-github-com-stretchr-testify)))
+ (home-page "https://github.com/keybase/go-ps")
+ (synopsis "Process list library for Go")
+ (description "Go-Ps is a library for Go that implements OS-specific APIs
+to list and manipulate processes in a safe way.")
+ (license license:expat))))
+
(define-public go-github-com-apparentlymart-go-openvpn-mgmt
(let ((commit "4d2ce95ae600ee04eeb020ee0997aabb82752210")
(revision "0"))