summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-06 16:23:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-07 09:10:44 +0300
commit4b4d4d7baef00df6e5b8ee14359195292fd37e36 (patch)
treee6fbefde0f7c71878b108eb0bdb80fa50692cf57
parent67ce43c0d3664ea1f45b155e8e8857cf30e02c46 (diff)
downloadguix-4b4d4d7baef00df6e5b8ee14359195292fd37e36.tar.gz
guix-4b4d4d7baef00df6e5b8ee14359195292fd37e36.tar.xz
gnu: openblas: Fix building on powerpc64le-linux.
* gnu/packages/maths.scm (openblas)[arguments]: Add make-flags to enable building for powerpc64le-linux.
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3d3d20d609..cd40e8eb99 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3843,13 +3843,17 @@ parts of it.")
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
- ;; Unfortunately, this is not supported on non-x86 architectures,
+ ;; Unfortunately, this is not supported on all architectures,
;; where it leads to failed builds.
,@(let ((system (or (%current-target-system) (%current-system))))
(cond
((or (string-prefix? "x86_64" system)
(string-prefix? "i686" system))
'("DYNAMIC_ARCH=1"))
+ ;; On some of these architectures the CPU can't be detected.
+ ((string-prefix? "powerpc64le" system)
+ '("DYNAMIC_ARCH=1"
+ "TARGET=GENERIC"))
;; On MIPS we force the "SICORTEX" TARGET, as for the other
;; two available MIPS targets special extended instructions
;; for Loongson cores are used.