summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-30 17:11:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-02 21:06:52 +0200
commit5f6887e839c10f0c905969d07baca4e03f453e82 (patch)
treed9bc144fb05f41d2a9dc85b8c6c0f4a0a941d3d7
parent0272ee499dbd985b2368c55530b16827b7926232 (diff)
downloadguix-5f6887e839c10f0c905969d07baca4e03f453e82.tar.gz
guix-5f6887e839c10f0c905969d07baca4e03f453e82.tar.xz
gnu: gcj: Remove broken symlink and conflicting files.
* gnu/packages/gcc.scm (gcj)[arguments]: Add a build phase to remove a broken symlink and generic stump binaries.
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c368b7df97..957917bf0b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -444,7 +444,18 @@ Go. It also includes runtime support libraries for these languages.")
(string-append jvm "/lib/tools.jar")))
(chmod target #o755)
#t))
- ,phases))))))
+ (alist-cons-after
+ 'install 'remove-broken-or-conflicting-files
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (for-each
+ delete-file
+ (append (find-files (string-append out "/lib/jvm/jre/lib")
+ "libjawt.so")
+ (find-files (string-append out "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcc.*)"))))
+ #t)
+ ,phases)))))))
(define ecj-bootstrap-4.8
(origin