summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-21 15:06:38 -0400
committerMark H Weaver <mhw@netris.org>2015-07-21 15:08:33 -0400
commit606a106fcc6e820e8b3a3c8b646d68a753f1fd09 (patch)
tree9eaf04bf42533b11811e5fb8352859f761fd5706
parentd739f48140e317602cebffd5fd3da92059a235fc (diff)
downloadguix-606a106fcc6e820e8b3a3c8b646d68a753f1fd09.tar.gz
guix-606a106fcc6e820e8b3a3c8b646d68a753f1fd09.tar.xz
gnu: hoedown: Replace 'fix-makefile' phase with make-flags.
* gnu/packages/markdown.scm (hoedown)[arguments]: Remove 'fix-makefile' phase. Add equivalent make-flags.
-rw-r--r--gnu/packages/markdown.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/markdown.scm b/gnu/packages/markdown.scm
index 58ca10277a..ee0edfc349 100644
--- a/gnu/packages/markdown.scm
+++ b/gnu/packages/markdown.scm
@@ -38,14 +38,8 @@
"0mmmkfayqgh6k39kbi3pq68mg03x35aiygy3zypxzvwx9y8b53ky"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'build 'fix-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" "gcc")
- (substitute* '("Makefile")
- (("/usr/local")
- (assoc-ref outputs "out")))
- #t))
+ '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
(delete 'configure)) ; no configure script
#:test-target "test"))
(native-inputs