summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-06-26 12:50:58 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-06-26 13:03:50 +0200
commit6ac69aae7fff06fd97060d9e0f462a09f2c07cde (patch)
tree8295c804c0094b236f4ca74f51c870bfef1c5233
parent9f641dd705649a2169d43da6ea30202bd61bdb15 (diff)
downloadguix-6ac69aae7fff06fd97060d9e0f462a09f2c07cde.tar.gz
guix-6ac69aae7fff06fd97060d9e0f462a09f2c07cde.tar.xz
gnu: Add sbcl-ieee-floats.
* gnu/packages/lisp.scm (sbcl-ieee-floats): New variable.
-rw-r--r--gnu/packages/lisp.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index fa592c6fa6..d7f3f01789 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5881,3 +5881,28 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(arguments
(substitute-keyword-arguments (package-arguments sbcl-iolib)
((#:asd-system-name _) "iolib/sockets")))))
+
+(define-public sbcl-ieee-floats
+ (let ((commit "566b51a005e81ff618554b9b2f0b795d3b29398d")
+ (revision "1"))
+ (package
+ (name "sbcl-ieee-floats")
+ (build-system asdf-build-system/sbcl)
+ (version (git-version "20170924" revision commit))
+ (home-page "https://github.com/marijnh/ieee-floats/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xyj49j9x3lc84cv3dhbf9ja34ywjk1c46dklx425fxw9mkwm83m"))))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (synopsis "IEEE 754 binary representation for floats in Common Lisp")
+ (description "This is a Common Lisp library that allows to convert
+floating point values to IEEE 754 binary representation.")
+ (license license:bsd-3))))