summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-07-05 12:58:13 -0400
committerLeo Famulari <leo@famulari.name>2022-07-05 18:46:24 -0400
commitc72c3e851bc93e6f7edb143399a6ae7620f62135 (patch)
treeee2a0c70aa02f9bff49f09cfc473533a52279c2c
parent43cf8861b8ff3e8b987b731f347e31ba8bdf00ae (diff)
downloadguix-c72c3e851bc93e6f7edb143399a6ae7620f62135.tar.gz
guix-c72c3e851bc93e6f7edb143399a6ae7620f62135.tar.xz
gnu: WebKit: Update to 2.36.4 [security fixes].
Fixes CVE-2022-22677 and CVE-2022-26710. * gnu/packages/webkit.scm (%webkit-version, webkitgtk, wpewebkit): Update to 2.36.4.
-rw-r--r--gnu/packages/webkit.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 42a2893a38..5a6d49c888 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -123,7 +123,7 @@ the WPE-flavored port of WebKit.")
engine that uses Wayland for graphics output.")
(license license:bsd-2)))
-(define %webkit-version "2.36.3")
+(define %webkit-version "2.36.4")
(define-public webkitgtk
(package
@@ -134,7 +134,7 @@ engine that uses Wayland for graphics output.")
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1lbqqjpqc9yiwpsvvagy1ag9vazbq7bvnvml53nvhi669s6cybvk"))
+ (base32 "1a72w9md2xvb82rd2sk3c7pqrvr28rqa8i4yq5ldjyd4hlgvxgmn"))
(patches (search-patches
"webkitgtk-adjust-bubblewrap-paths.patch"))))
(build-system cmake-build-system)
@@ -300,7 +300,7 @@ propagated by default) such as @code{gst-plugins-good} and
(uri (string-append "https://wpewebkit.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1j1gijb8jz15vz65sv5pml3shqk2sm6769kq7bzxm5vlrbmms9v6"))))
+ (base32 "08f0sz4d5bpgrgvkgby3fri3wk5474f66gvp3y39laflypnknyih"))))
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)