summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 19:00:34 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:20 -0400
commitead243bfb62c8a4c686402966c5ec9d0700c5f7e (patch)
treeda69911970789e5e71b1c3c638b60703d0e6a0de
parentd1f4ace68ef58a54398d7378be34f35ed2a5d1a7 (diff)
downloadguix-ead243bfb62c8a4c686402966c5ec9d0700c5f7e.tar.gz
guix-ead243bfb62c8a4c686402966c5ec9d0700c5f7e.tar.xz
gnu: Add go-github-com-operatorfoundation-monolith-go.
* gnu/packages/golang.scm (go-github-com-operatorfoundation-monolith-go): New variable.
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0d8239675e..daf64fd63e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,33 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-operatorfoundation-monolith-go
+ (package
+ (name "go-github-com-operatorfoundation-monolith-go")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/OperatorFoundation/monolith-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "066bqlgw5h7a3kxswqlv734asb7nw2y6snsn09yqk0ixj23qw22s"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ; ERROR: Generated bytes do not match correct answer.
+ #:unpack-path "github.com/OperatorFoundation/monolith-go"
+ #:import-path "github.com/OperatorFoundation/monolith-go/monolith"))
+ (propagated-inputs
+ `(("go-github-com-deckarep-golang-set"
+ ,go-github-com-deckarep-golang-set)))
+ (home-page "https://github.com/OperatorFoundation/monolith-go")
+ (synopsis "Byte sequences library")
+ (description "Monolith-Go is a Go library for working with byte sequences.")
+ (license license:expat)))
+
(define-public go-github-com-deckarep-golang-set
(package
(name "go-github-com-deckarep-golang-set")