summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:52 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-04 16:10:53 +0200
commitfdcd0133b2e452ce6e8bfbfc185cf3123c06cbfa (patch)
tree98a888d74e8e5e21701c753803d52ee8b322c73d
parentc8f49e5c704276620e83db5777d13a49726e9e80 (diff)
downloadguix-fdcd0133b2e452ce6e8bfbfc185cf3123c06cbfa.tar.gz
guix-fdcd0133b2e452ce6e8bfbfc185cf3123c06cbfa.tar.xz
gnu: Add trytond-stock-package-shipping-dpd.
* gnu/packages/tryton.scm (trytond-stock-package-shipping-dpd): New variable.
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 32f38d0892..9810a90d02 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages pdf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -3812,6 +3813,31 @@ packaging information about customer and supplier return shipments.")
interact with shipping service providers.")
(license license:gpl3+)))
+(define-public trytond-stock-package-shipping-dpd
+ (package
+ (name "trytond-stock-package-shipping-dpd")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_package_shipping_dpd" version))
+ (sha256
+ (base32 "11jn2i7gkxj4nck5fkp0j8n8r6vhsv26rcnmmmmdh1iqji7cv8yf"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_package_shipping_dpd"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs
+ (list python-pypdf2 trytond trytond-party trytond-product trytond-stock
+ trytond-stock-package trytond-stock-package-shipping
+ trytond-stock-shipment-measurements python-zeep))
+ (home-page
+ "https://docs.tryton.org/projects/modules-stock-package-shipping-dpd")
+ (synopsis "DPD connector for the Tryton application platform")
+ (description "The @emph{Stock Package Shipping DPD} Tryton module allows
+you to generate the DPD label using the DPD webservices. DPD has many
+different web services, the module supports:")
+ (license license:gpl3+)))
+
(define-public trytond-stock-package-shipping-ups
(package
(name "trytond-stock-package-shipping-ups")