summaryrefslogtreecommitdiff
path: root/gnu/packages/accessibility.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-25 16:04:14 +0000
committerLeo Famulari <leo@famulari.name>2017-05-27 13:35:02 -0400
commit574e4e16d82bdc76b7c2ba726518047cdf1edf0b (patch)
tree63a1d1264a1aa6114c0cb99a20b6b398c6911c9a /gnu/packages/accessibility.scm
parent16855482fd0bcc2460028c701498d35d248a6269 (diff)
downloadguix-574e4e16d82bdc76b7c2ba726518047cdf1edf0b.tar.gz
guix-574e4e16d82bdc76b7c2ba726518047cdf1edf0b.tar.xz
gnu: Add florence.
* gnu/packages/accessibility.scm: New file. * gnu/local.mk: (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/accessibility.scm')
-rw-r--r--gnu/packages/accessibility.scm78
1 files changed, 78 insertions, 0 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
new file mode 100644
index 0000000000..0795808768
--- /dev/null
+++ b/gnu/packages/accessibility.scm
@@ -0,0 +1,78 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages accessibility)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config))
+
+(define-public florence
+ (package
+ (name "florence")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/florence/florence/" version
+ "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "07h9qm22krlwayhzvc391lr23vicw81s48g7rirvx1fj0zyr4aa2"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags (list "--with-xtst"
+ "--without-docs"
+ "--with-notification")))
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("libglade" ,libglade)
+ ("librsvg" ,librsvg)
+ ("gstreamer" ,gstreamer)
+ ("cairo" ,cairo)
+ ("gtk+" ,gtk+)
+ ("libxtst" ,libxtst)
+ ("libxcomposite" ,libxcomposite)
+ ("libnotify" ,libnotify)))
+ (native-inputs
+ `(("gettext-minimal" ,gettext-minimal)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://florence.sourceforge.net/")
+ (synopsis "Extensible, scalable virtual keyboard for X11")
+ (description
+ "Florence is an extensible scalable virtual keyboard for X11.
+It is useful for people who can't use a real hardware keyboard (for
+example for people with disabilities), but you must be able to use
+a pointing device (as a mouse, a trackball, a touchscreen or opengazer).
+
+Florence stays out of your way when you don't need it: it appears on the
+screen only when you need it. A timer-based auto-click input method is
+available to help to click.")
+ ;; The documentation is under FDL1.2, but we do not install the
+ ;; documentation.
+ (license license:gpl2+)))