summaryrefslogtreecommitdiff
path: root/gnu/packages/ada.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/ada.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
guix-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.xz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ada.scm')
-rw-r--r--gnu/packages/ada.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/ada.scm b/gnu/packages/ada.scm
index edd623be9d..8f8b68d80d 100644
--- a/gnu/packages/ada.scm
+++ b/gnu/packages/ada.scm
@@ -181,43 +181,3 @@ specification in our Python DSL and Langkit will generate for you an
Ada library with bindings for the C and Python programming languages.")
(home-page "https://github.com/AdaCore/langkit/")
(license license:gpl3+)))) ; and gcc runtime library exception
-
-(define-public python2-libadalang
- (let ((commit "9b205e9bacdd50a68117727332e16fbef5f6ac49")
- (revision "0"))
- (package
- (name "python2-libadalang")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AdaCore/libadalang")
- (commit commit)))
- (sha256
- (base32
- "06hsnzj2syqpq2yhg1bb0zil7ydbyqkdmkjbf8j9b5sdgkyh5xrp"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system python-build-system)
- (native-inputs
- `(("python2-langkit" ,python2-langkit)
- ("python2-quex" ,python2-quex-0.67.3)))
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda _
- (invoke "python2" "ada/manage.py" "generate")
- (invoke "python2" "ada/manage.py" "build")))
- (replace 'check
- (lambda _
- (invoke "python2" "ada/manage.py" "test")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (invoke "python2" "ada/manage.py" "install" out)))))))
- (synopsis "Semantic Analysis for Ada in Python")
- (description "@code{libadalang} provides a high-performance semantic
-engine for the Ada programming language.")
- (home-page "https://github.com/AdaCore/libadalang")
- (license license:gpl3)))) ; and gcc runtime gcc lib exception