summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
commit1a6be557010bcf55d1c6d2e38ab1f8b5efe7303b (patch)
tree3a20b24e3b3aad81a8a7478010b75e0dcea316a1 /gnu/packages/admin.scm
parent4577f3c6b60ea100e521c246fb169d6c05214b20 (diff)
downloadguix-1a6be557010bcf55d1c6d2e38ab1f8b5efe7303b.tar.gz
guix-1a6be557010bcf55d1c6d2e38ab1f8b5efe7303b.tar.xz
gnu: jc: Update to 1.19.0.
* gnu/packages/admin.scm (jc): Update to 1.19.0. [arguments]: Add a new 'hack-time-zone phase.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d22753c64f..af75dee697 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4541,7 +4541,7 @@ supplied by the user when logging in.")
(define-public jc
(package
(name "jc")
- (version "1.13.4")
+ (version "1.19.0")
(source
(origin
;; The PyPI tarball lacks the test suite.
@@ -4551,8 +4551,16 @@ supplied by the user when logging in.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rwvyyrdnw43pixp8h51rncq2inc9pbbj1j2191y5si00pjw34zr"))))
+ (base32 "021zk0y8kb6v3qf3hwfg8qjzzmrca039nz3fjywiy2njmbhr8hyi"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX Guix's America/Los_Angeles time zone is somehow broken.
+ (add-before 'check 'hack-time-zone
+ (lambda _
+ (substitute* (find-files "tests" "^test.*\\.py$")
+ (("America/Los_Angeles") "PST8PDT")))))))
(propagated-inputs
(list python-pygments python-ruamel.yaml python-xmltodict))
(home-page "https://github.com/kellyjonbrazil/jc")