summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/autotools.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.xz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 57efc4c477..a8bf36a966 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -63,8 +63,7 @@
("perl" ,perl)
("m4" ,m4)))
(native-inputs
- `(("perl" ,perl)
- ("m4" ,m4)))
+ (list perl m4))
(arguments
`(;; XXX: testsuite: 209 and 279 failed. The latter is an impurity. It
;; should use our own "cpp" instead of "/lib/cpp".
@@ -313,7 +312,7 @@ contributed as free software by the community.")
(base32
"0gv7g61ja9q9zg1m30k4snqwwy1kq7b4df6sb7d2qra7kbdq8af1"))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)))
+ (inputs (list perl))
(synopsis "Process generated build logs")
(description "Autobuild is a package that processes build logs generated
when building software. Autobuild is primarily focused on packages using
@@ -465,7 +464,7 @@ Makefile, simplifying the entire process for the developer.")
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
(patches (search-patches "libtool-skip-tests2.patch"))))
(build-system gnu-build-system)
- (propagated-inputs `(("m4" ,m4)))
+ (propagated-inputs (list m4))
(native-inputs `(("m4" ,m4)
("perl" ,perl)
;; XXX: this shouldn't be necessary, but without it test
@@ -562,7 +561,7 @@ complexity of working with shared libraries across platforms.")
(install-file "doc/config.sub.1" man1)
#t))))))
(native-inputs
- `(("help2man" ,help2man)))
+ (list help2man))
(home-page "https://savannah.gnu.org/projects/config")
(synopsis "Ubiquitous config.guess and config.sub scripts")
(description "The `config.guess' script tries to guess a canonical system triple,
@@ -618,7 +617,7 @@ configuration in nearly all GNU packages (and many others).")
(("/usr/bin/env python") (which "python3")))
#t)))))
(inputs
- `(("python" ,python-3)))
+ (list python-3))
(synopsis "@command{configure} interface for Python-based packages")
(description
"GNU pyconfigure provides template files for easily implementing