summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-05-01 12:58:25 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-05-01 14:13:50 -0700
commiteb305784bfa229043d53ce60c130e25b07e1447f (patch)
tree18505d4ca3ba445f6fa514c89dd895b14233d828 /gnu/packages/bootloaders.scm
parent3a851d45576e046d696fcf35b34d57b2cd28ea49 (diff)
downloadguix-eb305784bfa229043d53ce60c130e25b07e1447f.tar.gz
guix-eb305784bfa229043d53ce60c130e25b07e1447f.tar.xz
gnu: u-boot-pinebook-pro-rk3399: Update to version 2021.07-rc1.
Version 2021.07-rc1 supports video output on the eDP panel. * gnu/packages/bootloaders.scm (u-boot-2021.07): New variable. (u-boot-pinebook-pro-rk3399)[source, version]: Use u-boot-2021.07.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index e77466cf26..56bef57cb7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -513,6 +513,21 @@ tree binary files. These are board description files used by Linux and BSD.")
also initializes the boards (RAM etc).")
(license license:gpl2+)))
+(define-public u-boot-2021.07
+ (package
+ (inherit u-boot)
+ (version "2021.07-rc1")
+ (source (origin
+ (patches
+ (list %u-boot-rockchip-inno-usb-patch))
+ (method url-fetch)
+ (uri (string-append
+ "https://ftp.denx.de/pub/u-boot/"
+ "u-boot-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "12krpy85iwy40xlhqb61d0d4bzj0sbn9sdf8brn57m4cjh1svaya"))))))
+
(define-public u-boot-tools
(package
(inherit u-boot)
@@ -913,6 +928,8 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(let ((base (make-u-boot-package "pinebook-pro-rk3399" "aarch64-linux-gnu")))
(package
(inherit base)
+ (version (package-version u-boot-2021.07))
+ (source (package-source u-boot-2021.07))
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)