summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 13:45:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:29 -0400
commite96c2dcabf898c8aaebe4191922cb186f43f376c (patch)
treef3ada8298570e315a1682d79b11075422dfba06a /gnu/packages/check.scm
parent3ce8459aa728ce85bd1f67194539a33cec0a9d1b (diff)
downloadguix-e96c2dcabf898c8aaebe4191922cb186f43f376c.tar.gz
guix-e96c2dcabf898c8aaebe4191922cb186f43f376c.tar.xz
gnu: Add python-pytest-enabler-bootstrap.
* gnu/packages/check.scm (python-pytest-enabler-bootstrap): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1db4457dde..135fd671a2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2200,6 +2200,31 @@ style test suites, summarizing their results, and providing indication of
failures.")
(license license:ncsa)))
+;;; This is marked as a bootstrap package because it propagates bootstrapped
+;;; versions of jaraco-context and jaraco-functools.
+(define-public python-pytest-enabler-bootstrap
+ (hidden-package
+ (package
+ (name "python-pytest-enabler-bootstrap")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-enabler" version))
+ (sha256
+ (base32 "023ymm0r2gpn5q7aikvx567s507j0zk46w41w6gxb69c688zgs73"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f))
+ (propagated-inputs
+ (list python-jaraco-context-bootstrap
+ python-jaraco-functools-bootstrap
+ python-toml))
+ (native-inputs (list python-setuptools-scm))
+ (home-page "https://github.com/jaraco/pytest-enabler")
+ (synopsis "Enable installed pytest plugins")
+ (description "Enable installed pytest plugins")
+ (license license:expat))))
+
(define-public python-pytest-freezegun
(package
(name "python-pytest-freezegun")